[Intel-gfx] [PATCH 3/3] drm/i915/selftests: Replace open-coded i915_address_space_init()
Tvrtko Ursulin
tvrtko.ursulin at linux.intel.com
Thu Jul 5 09:55:57 UTC 2018
On 05/07/2018 07:56, Chris Wilson wrote:
> Use i915_address_space_init() rather than open-code it inside
> mock_ppgtt() as we will forget to keep it in sync.
>
> Signed-off-by: Chris Wilson <chris at chris-wilson.co.uk>
> ---
> drivers/gpu/drm/i915/selftests/mock_gtt.c | 6 +-----
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/selftests/mock_gtt.c b/drivers/gpu/drm/i915/selftests/mock_gtt.c
> index 07df5c399ec1..a140ea5c3a7c 100644
> --- a/drivers/gpu/drm/i915/selftests/mock_gtt.c
> +++ b/drivers/gpu/drm/i915/selftests/mock_gtt.c
> @@ -70,11 +70,7 @@ mock_ppgtt(struct drm_i915_private *i915,
> ppgtt->vm.total = round_down(U64_MAX, PAGE_SIZE);
> ppgtt->vm.file = ERR_PTR(-ENODEV);
>
> - INIT_LIST_HEAD(&ppgtt->vm.active_list);
> - INIT_LIST_HEAD(&ppgtt->vm.inactive_list);
> - INIT_LIST_HEAD(&ppgtt->vm.unbound_list);
> -
> - drm_mm_init(&ppgtt->vm.mm, 0, ppgtt->vm.total);
> + i915_address_space_init(&ppgtt->vm, i915);
>
> ppgtt->vm.clear_range = nop_clear_range;
> ppgtt->vm.insert_page = mock_insert_page;
>
Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin at intel.com>
Regards,
Tvrtko
More information about the Intel-gfx
mailing list