[Intel-gfx] [PATCH 12/12] usb: use for_each_if
Daniel Vetter
daniel.vetter at ffwll.ch
Mon Jul 9 08:36:50 UTC 2018
Avoids the inverted condition compared to the open-coded version.
Signed-off-by: Daniel Vetter <daniel.vetter at intel.com>
Cc: Greg Kroah-Hartman <gregkh at linuxfoundation.org>
Cc: linux-usb at vger.kernel.org
---
include/linux/usb.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/usb.h b/include/linux/usb.h
index 4cdd515a4385..a9da7237c619 100644
--- a/include/linux/usb.h
+++ b/include/linux/usb.h
@@ -732,7 +732,7 @@ extern struct usb_device *usb_hub_find_child(struct usb_device *hdev,
for (port1 = 1, child = usb_hub_find_child(hdev, port1); \
port1 <= hdev->maxchild; \
child = usb_hub_find_child(hdev, ++port1)) \
- if (!child) continue; else
+ for_each_if (child)
/* USB device locking */
#define usb_lock_device(udev) device_lock(&(udev)->dev)
--
2.18.0
More information about the Intel-gfx
mailing list