[Intel-gfx] [PATCH v2 0/7] Make GEN macros more similar

Lucas De Marchi lucas.de.marchi at gmail.com
Wed Nov 28 17:22:23 UTC 2018

On Tue, Nov 27, 2018 at 04:19:23PM -0800, Rodrigo Vivi wrote:
> > Then on the question of IS_ prefix or not, I don't feel very strongly about
> > it. IS_ has a nice parallel with HAS_ and IS_platform, but I agree it
> > doesn't look the prettiest (IS_GT_GEN). So don't know, whatever the vote
> > ends up being.
> okay, the HAS_ parallel is a good point...
> but still in that case my brain prefers
> than
> because "FEATURE what?" Like if feature was more "transitive" requiring something else.
> while for "is" my brain prefers
> than
> because here it seems more "intransitive"...
> like... self contained meaning where "is" can be implicit.

for me both IS_PLATFORM and PLATFORM make sense. IS_ prefix is used in
several other places for things like that. I just don't like the outcome
of having it: gigantic horrendous macros like IS_GT_GEN_RANGE().

Lucas De Marchi

More information about the Intel-gfx mailing list