[Intel-gfx] [PATCH v3 0/3] drm/i915: introduce macros to define register contents
Jani Nikula
jani.nikula at intel.com
Wed Feb 27 17:02:35 UTC 2019
v3 of [1] with naming hopefully settled (fingers crossed), and some more
compile time checks, documentation and other polish added.
The naming scheme of the local wrappers/copies of bit fiddling macros is
to just use REG_ prefix for the regular kernel ones, with hopefully
minimal confusion. So we end up with:
REG_BIT()
REG_GENMASK()
REG_FIELD_PREP()
REG_FIELD_GET()
We can also use the same macros in i915_reg.h and rest of the driver,
with no mixed use for register contents. Indeed some of the regular
kernel macros lead to non-u32 types being used.
BR,
Jani.
[1] http://mid.mail-archive.com/cover.1547726792.git.jani.nikula@intel.com
Jani Nikula (3):
drm/i915: introduce REG_BIT() and REG_GENMASK() to define register
contents
drm/i915: deprecate _SHIFT in favor of _MASK passed to accessors
drm/i915: use REG_FIELD_PREP() to define register bitfield values
drivers/gpu/drm/i915/i915_reg.h | 182 +++++++++++++++++++-----------
drivers/gpu/drm/i915/intel_dp.c | 40 +++----
drivers/gpu/drm/i915/intel_lvds.c | 40 +++----
3 files changed, 151 insertions(+), 111 deletions(-)
--
2.20.1
More information about the Intel-gfx
mailing list