[Intel-gfx] [RESUBMIT PATCH v3 0/6] drm/i915: Rename functions to match their entry points
Janusz Krzysztofik
janusz.krzysztofik at linux.intel.com
Fri Jul 12 11:24:24 UTC 2019
Need for this was identified while working on split of driver unbind
path into _remove() and _release() parts. Consistency in function
naming has been recognized as helpful when trying to work out which
phase the code is in.
v2: * early_probe pairs better with late_release (Chris),
* exclude patch 6/6 "drm/i915: Rename "inject_load_failure" module
parameter" for now, it requires updates on user (IGT) side
* rebase on top of "drm/i915: Drop extern qualifiers from header
function prototypes"
v3: * fix typo in commit message of 3/5 (now 4/6) (Joonas)
* bundle with "drm/i915: Drop extern qualifiers from header
function prototypes", which the series depends on, as 1/6 (Chris)
Resubmitting with Reviewed-by: clauses added.
Janusz Krzysztofik (6):
drm/i915: Drop extern qualifiers from header function prototypes
drm/i915: Rename "_load"/"_unload" to match PCI entry points
drm/i915: Replace "_load" with "_probe" consequently
drm/i915: Propagate "_release" function name suffix down
drm/i915: Propagate "_remove" function name suffix down
drm/i915: Propagate "_probe" function name suffix down
drivers/gpu/drm/i915/display/intel_bios.c | 4 +-
drivers/gpu/drm/i915/display/intel_bios.h | 2 +-
.../gpu/drm/i915/display/intel_connector.c | 2 +-
drivers/gpu/drm/i915/display/intel_display.c | 2 +-
.../drm/i915/display/intel_display_power.c | 6 +-
.../drm/i915/display/intel_display_power.h | 2 +-
drivers/gpu/drm/i915/gem/i915_gem_object.h | 2 +-
drivers/gpu/drm/i915/gt/intel_engine_cs.c | 2 +-
drivers/gpu/drm/i915/gvt/gtt.h | 13 ++-
drivers/gpu/drm/i915/i915_drv.c | 107 +++++++++---------
drivers/gpu/drm/i915/i915_drv.h | 61 +++++-----
drivers/gpu/drm/i915/i915_gem.c | 12 +-
drivers/gpu/drm/i915/i915_gem_gtt.c | 4 +-
drivers/gpu/drm/i915/i915_gem_gtt.h | 2 +-
drivers/gpu/drm/i915/i915_irq.h | 4 +-
drivers/gpu/drm/i915/i915_pci.c | 6 +-
drivers/gpu/drm/i915/intel_gvt.c | 7 +-
drivers/gpu/drm/i915/intel_gvt.h | 5 +-
drivers/gpu/drm/i915/intel_runtime_pm.c | 2 +-
drivers/gpu/drm/i915/intel_runtime_pm.h | 2 +-
drivers/gpu/drm/i915/intel_uncore.c | 2 +-
drivers/gpu/drm/i915/intel_wopcm.c | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_bdw.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_bxt.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_cflgt2.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_cflgt3.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_chv.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_cnl.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_glk.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_hsw.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_icl.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_kblgt2.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_kblgt3.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_sklgt2.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_sklgt3.h | 2 +-
drivers/gpu/drm/i915/oa/i915_oa_sklgt4.h | 2 +-
include/drm/i915_drm.h | 10 +-
37 files changed, 145 insertions(+), 144 deletions(-)
--
2.21.0
More information about the Intel-gfx
mailing list