[Intel-gfx] [PATCH 2/6] drm/i915: move gt_cleanup_early out of gem_cleanup_early
Chris Wilson
chris at chris-wilson.co.uk
Tue Jul 30 15:12:07 UTC 2019
Quoting Daniele Ceraolo Spurio (2019-07-30 15:56:57)
>
>
> On 7/30/19 1:01 AM, Chris Wilson wrote:
> > Quoting Tvrtko Ursulin (2019-07-30 08:19:18)
> >>
> >> On 30/07/2019 00:47, Daniele Ceraolo Spurio wrote:
> >>> We don't call the init_early function from within the gem code, so we
> >>> shouldn't do it for the cleanup either.
> >>>
> >>> Signed-off-by: Daniele Ceraolo Spurio <daniele.ceraolospurio at intel.com>
> >>> Cc: Chris Wilson <chris at chris-wilson.co.uk>
> >>> Cc: Tvrtko Ursulin <tvrtko.ursulin at linux.intel.com>
> >>> ---
> >>> drivers/gpu/drm/i915/i915_drv.c | 2 ++
> >>> drivers/gpu/drm/i915/i915_gem.c | 2 --
> >>> 2 files changed, 2 insertions(+), 2 deletions(-)
> >>>
> >>> diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
> >>> index f2d3d754af37..934e605e2466 100644
> >>> --- a/drivers/gpu/drm/i915/i915_drv.c
> >>> +++ b/drivers/gpu/drm/i915/i915_drv.c
> >>> @@ -951,6 +951,7 @@ static int i915_driver_early_probe(struct drm_i915_private *dev_priv)
> >>> intel_uc_cleanup_early(&dev_priv->gt.uc);
> >>> i915_gem_cleanup_early(dev_priv);
> >>> err_workqueues:
> >>> + intel_gt_cleanup_early(&dev_priv->gt);
> >>> i915_workqueues_cleanup(dev_priv);
> >>> return ret;
> >>> }
> >>> @@ -966,6 +967,7 @@ static void i915_driver_late_release(struct drm_i915_private *dev_priv)
> >>> intel_power_domains_cleanup(dev_priv);
> >>> intel_uc_cleanup_early(&dev_priv->gt.uc);
> >>> i915_gem_cleanup_early(dev_priv);
> >>> + intel_gt_cleanup_early(&dev_priv->gt);
> >
> > Note the change in naming convention, intel_gt_driver_late_release().
> > -Chris
> >
>
> Does it make sense to flip only the gt function? it'd look terribly out
> of place close to all those other cleanup_early() calls. I can follow up
> with a patch to flip them all at the same time if that works for you.
Baby steps, the consistency is in the function callgraphs -- it looks
out of place to have late_release call cleanup_early :)
-Chris
More information about the Intel-gfx
mailing list