[Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for drm/print: cleanup and new drm_device based logging

Patchwork patchwork at emeril.freedesktop.org
Wed Oct 9 16:47:18 UTC 2019


== Series Details ==

Series: drm/print: cleanup and new drm_device based logging
URL   : https://patchwork.freedesktop.org/series/67795/
State : warning

== Summary ==

$ dim checkpatch origin/drm-tip
89aa720fbb9a drm/i915: use drm_debug_enabled() to check for debug categories
ad0afd4a8ac2 drm/nouveau: use drm_debug_enabled() to check for debug categories
f19cd5fa4e1d drm/amdgpu: use drm_debug_enabled() to check for debug categories
4169799b13df drm/print: rename drm_debug to __drm_debug to discourage use
2173f3c87495 drm/print: underscore prefix functions that should be private to print
c44938e9aa7c drm/print: convert debug category macros into an enum
5f8536cabd52 drm/print: group logging functions by prink or device based
-:202: CHECK:LINE_SPACING: Please don't use multiple blank lines
#202: FILE: include/drm/drm_print.h:478:
+
+

total: 0 errors, 0 warnings, 1 checks, 193 lines checked
48c9c0212611 drm/print: introduce new struct drm_device based logging macros
-:73: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#73: FILE: include/drm/drm_print.h:429:
+#define __drm_printk(drm, level, type, fmt, ...)			\
+	dev_##level##type(drm->dev, "[drm] " fmt, ##__VA_ARGS__)

-:76: CHECK:LINE_SPACING: Please don't use multiple blank lines
#76: FILE: include/drm/drm_print.h:432:
+
+

-:78: ERROR:SPACING: space required after that ',' (ctx:VxO)
#78: FILE: include/drm/drm_print.h:434:
+	__drm_printk(drm, info,, fmt, ##__VA_ARGS__)
 	                      ^

-:81: ERROR:SPACING: space required after that ',' (ctx:VxO)
#81: FILE: include/drm/drm_print.h:437:
+	__drm_printk(drm, notice,, fmt, ##__VA_ARGS__)
 	                        ^

-:84: ERROR:SPACING: space required after that ',' (ctx:VxO)
#84: FILE: include/drm/drm_print.h:440:
+	__drm_printk(drm, warn,, fmt, ##__VA_ARGS__)
 	                      ^

-:87: ERROR:SPACING: space required after that ',' (ctx:VxO)
#87: FILE: include/drm/drm_print.h:443:
+	__drm_printk(drm, err,, "*ERROR* " fmt, ##__VA_ARGS__)
 	                     ^

-:89: CHECK:LINE_SPACING: Please don't use multiple blank lines
#89: FILE: include/drm/drm_print.h:445:
+
+

-:102: CHECK:LINE_SPACING: Please don't use multiple blank lines
#102: FILE: include/drm/drm_print.h:458:
+
+

-:106: CHECK:LINE_SPACING: Please don't use multiple blank lines
#106: FILE: include/drm/drm_print.h:462:
+
+

-:107: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#107: FILE: include/drm/drm_print.h:463:
+#define drm_dbg_core(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_CORE, fmt, ##__VA_ARGS__)

-:109: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#109: FILE: include/drm/drm_print.h:465:
+#define drm_dbg(drm, fmt, ...)						\
+	drm_dev_dbg(drm->dev, DRM_UT_DRIVER, fmt, ##__VA_ARGS__)

-:111: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#111: FILE: include/drm/drm_print.h:467:
+#define drm_dbg_kms(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_KMS, fmt, ##__VA_ARGS__)

-:113: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#113: FILE: include/drm/drm_print.h:469:
+#define drm_dbg_prime(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_PRIME, fmt, ##__VA_ARGS__)

-:115: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#115: FILE: include/drm/drm_print.h:471:
+#define drm_dbg_atomic(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_ATOMIC, fmt, ##__VA_ARGS__)

-:117: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#117: FILE: include/drm/drm_print.h:473:
+#define drm_dbg_vbl(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_VBL, fmt, ##__VA_ARGS__)

-:119: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#119: FILE: include/drm/drm_print.h:475:
+#define drm_dbg_state(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_STATE, fmt, ##__VA_ARGS__)

-:121: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#121: FILE: include/drm/drm_print.h:477:
+#define drm_dbg_lease(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_LEASE, fmt, ##__VA_ARGS__)

-:123: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#123: FILE: include/drm/drm_print.h:479:
+#define drm_dbg_dp(drm, fmt, ...)					\
+	drm_dev_dbg(drm->dev, DRM_UT_DP, fmt, ##__VA_ARGS__)

-:126: CHECK:LINE_SPACING: Please don't use multiple blank lines
#126: FILE: include/drm/drm_print.h:482:
+
+

total: 4 errors, 0 warnings, 15 checks, 79 lines checked



More information about the Intel-gfx mailing list