[Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for drm/print: cleanup and new drm_device based logging (rev3)
Patchwork
patchwork at emeril.freedesktop.org
Mon Oct 28 18:49:06 UTC 2019
== Series Details ==
Series: drm/print: cleanup and new drm_device based logging (rev3)
URL : https://patchwork.freedesktop.org/series/67795/
State : warning
== Summary ==
$ dim checkpatch origin/drm-tip
40c33aad0053 drm/i915: use drm_debug_enabled() to check for debug categories
98a1b348acd0 drm/nouveau: use drm_debug_enabled() to check for debug categories
9fd22e6ab31c drm/amdgpu: use drm_debug_enabled() to check for debug categories
87f85c36af54 drm/print: rename drm_debug to __drm_debug to discourage use
38759991f3bd drm/print: underscore prefix functions that should be private to print
a43e2082e8f4 drm/print: convert debug category macros into an enum
d11f6509835f drm/print: group logging functions by prink or device based
-:202: CHECK:LINE_SPACING: Please don't use multiple blank lines
#202: FILE: include/drm/drm_print.h:478:
+
+
total: 0 errors, 0 warnings, 1 checks, 193 lines checked
6d6978fc4683 drm/print: introduce new struct drm_device based logging macros
-:77: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#77: FILE: include/drm/drm_print.h:429:
+#define __drm_printk(drm, level, type, fmt, ...) \
+ dev_##level##type(drm->dev, "[drm] " fmt, ##__VA_ARGS__)
-:80: CHECK:LINE_SPACING: Please don't use multiple blank lines
#80: FILE: include/drm/drm_print.h:432:
+
+
-:82: ERROR:SPACING: space required after that ',' (ctx:VxO)
#82: FILE: include/drm/drm_print.h:434:
+ __drm_printk(drm, info,, fmt, ##__VA_ARGS__)
^
-:85: ERROR:SPACING: space required after that ',' (ctx:VxO)
#85: FILE: include/drm/drm_print.h:437:
+ __drm_printk(drm, notice,, fmt, ##__VA_ARGS__)
^
-:88: ERROR:SPACING: space required after that ',' (ctx:VxO)
#88: FILE: include/drm/drm_print.h:440:
+ __drm_printk(drm, warn,, fmt, ##__VA_ARGS__)
^
-:91: ERROR:SPACING: space required after that ',' (ctx:VxO)
#91: FILE: include/drm/drm_print.h:443:
+ __drm_printk(drm, err,, "*ERROR* " fmt, ##__VA_ARGS__)
^
-:93: CHECK:LINE_SPACING: Please don't use multiple blank lines
#93: FILE: include/drm/drm_print.h:445:
+
+
-:106: CHECK:LINE_SPACING: Please don't use multiple blank lines
#106: FILE: include/drm/drm_print.h:458:
+
+
-:110: CHECK:LINE_SPACING: Please don't use multiple blank lines
#110: FILE: include/drm/drm_print.h:462:
+
+
-:111: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#111: FILE: include/drm/drm_print.h:463:
+#define drm_dbg_core(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_CORE, fmt, ##__VA_ARGS__)
-:113: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#113: FILE: include/drm/drm_print.h:465:
+#define drm_dbg(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_DRIVER, fmt, ##__VA_ARGS__)
-:115: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#115: FILE: include/drm/drm_print.h:467:
+#define drm_dbg_kms(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_KMS, fmt, ##__VA_ARGS__)
-:117: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#117: FILE: include/drm/drm_print.h:469:
+#define drm_dbg_prime(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_PRIME, fmt, ##__VA_ARGS__)
-:119: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#119: FILE: include/drm/drm_print.h:471:
+#define drm_dbg_atomic(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_ATOMIC, fmt, ##__VA_ARGS__)
-:121: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#121: FILE: include/drm/drm_print.h:473:
+#define drm_dbg_vbl(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_VBL, fmt, ##__VA_ARGS__)
-:123: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#123: FILE: include/drm/drm_print.h:475:
+#define drm_dbg_state(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_STATE, fmt, ##__VA_ARGS__)
-:125: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#125: FILE: include/drm/drm_print.h:477:
+#define drm_dbg_lease(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_LEASE, fmt, ##__VA_ARGS__)
-:127: CHECK:MACRO_ARG_PRECEDENCE: Macro argument 'drm' may be better as '(drm)' to avoid precedence issues
#127: FILE: include/drm/drm_print.h:479:
+#define drm_dbg_dp(drm, fmt, ...) \
+ drm_dev_dbg(drm->dev, DRM_UT_DP, fmt, ##__VA_ARGS__)
-:130: CHECK:LINE_SPACING: Please don't use multiple blank lines
#130: FILE: include/drm/drm_print.h:482:
+
+
total: 4 errors, 0 warnings, 15 checks, 79 lines checked
More information about the Intel-gfx
mailing list