[Intel-gfx] [PATCH v4] drm/i915/gt: move remaining debugfs interfaces into gt

Andi Shyti andi at etezian.org
Tue Mar 31 22:21:13 UTC 2020


On Tue, Mar 31, 2020 at 11:10:55PM +0100, Chris Wilson wrote:
> Quoting Andi Shyti (2020-03-31 23:04:32)
> > From: Andi Shyti <andi.shyti at intel.com>
> > 
> > The following interfaces:
> > 
> > i915_wedged
> > i915_forcewake_user
> > i915_gem_interrupt
> > i915_sseu_status
> > 
> > are dependent on gt values. Put them inside gt/ and drop the
> > "i915_" prefix name. This would be the new structure:
> > 
> >   gt
> >   |
> >   +-- forcewake_user
> >   |
> >   +-- interrupt_info
> >   |
> >   +-- sseu_status
> >   |
> >   +-- wedge
> > 
> > Signed-off-by: Andi Shyti <andi.shyti at intel.com>
> > ---
> > Hi,
> > 
> > this patch is the first of a series that aims to refactor the
> > debugfs structure in the i915. Some changes will affect the
> > debugfs framework as well.
> > 
> > It has gone through a series of offline reviews mainly from
> > Tvrtko.
> > 
> > Thanks Tvrtko for the review,
> > Andi
> > 
> > Changelog
> > =========
> > v4:
> >  - interrupt and sseu debugfs interface are moved to their own
> >    "debugfs_gt_irq" and "debugfs_gt_sseu" files
> >  - reset functions are renamed to reset_show/store
> > v3:
> >  - better arrangement of what should stay in i915_debugfs and
> >    what needs to be moved under gt/
> >  - more use of the local "uncore" and "i915" variables to improve
> >    readability
> > v2:
> >  - dropped changes on "drop_caches", they were indeed irrelevant
> >  - improved interrupt info function
> > 
> >  drivers/gpu/drm/i915/Makefile             |   2 +
> >  drivers/gpu/drm/i915/gt/debugfs_gt.c      |  50 ++-
> >  drivers/gpu/drm/i915/gt/debugfs_gt_irq.c  | 162 ++++++++++
> >  drivers/gpu/drm/i915/gt/debugfs_gt_irq.h  |  15 +
> >  drivers/gpu/drm/i915/gt/debugfs_gt_pm.c   |  32 ++
> >  drivers/gpu/drm/i915/gt/debugfs_gt_sseu.c | 282 ++++++++++++++++
> >  drivers/gpu/drm/i915/gt/debugfs_gt_sseu.h |  16 +
> 
> It's gt/intel_sseu.[ch] so I would have opted for debugfs_sseu.[ch]
> 
> >  static const struct drm_info_list i915_debugfs_list[] = {
> >         {"i915_capabilities", i915_capabilities, 0},
> >         {"i915_gem_objects", i915_gem_object_info, 0},
> > @@ -1868,7 +1500,6 @@ static const struct drm_info_list i915_debugfs_list[] = {
> >         {"i915_rcs_topology", i915_rcs_topology, 0},
> 
> rcs_topology is basically sseu and one imagines would fit nicely inside
> debugfs/gt/
> 
> Other than those nits,
> Reviewed-by: Chris Wilson <chris at chris-wilson.co.uk>

I can do this in a next patch, I think it would be a different
kind of change.

...and I also need to add Tvrtko's r-b he reviewed it in a
different context, but I wanted him to be aware publicly.

I guess he wouldn't mind me doing it for him now :/

Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin at intel.com>

Thank you!
Andi


More information about the Intel-gfx mailing list