[Intel-gfx] [PATCH] drm/i915: Fix the DDI encoder names

Lucas De Marchi lucas.demarchi at intel.com
Wed Nov 18 05:43:12 UTC 2020


On Tue, Nov 17, 2020 at 05:40:28PM +0200, Ville Syrjälä wrote:
>From: Ville Syrjälä <ville.syrjala at linux.intel.com>
>
>I totally fumbled the ?: usage when generating the DDI encoder
>names. Reverse the things that need reversing, and to make it
>a bit less messy add a few macros to hide the arithmetic on the
>port enums.
>
>Cc: Jani Nikula <jani.nikula at linux.intel.com>
>Fixes: 2d709a5a624c ("drm/i915: Give DDI encoders even better names")
>Signed-off-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
>---
> drivers/gpu/drm/i915/display/intel_ddi.c | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
>diff --git a/drivers/gpu/drm/i915/display/intel_ddi.c b/drivers/gpu/drm/i915/display/intel_ddi.c
>index 9d80e47e9558..2de2c69db7f2 100644
>--- a/drivers/gpu/drm/i915/display/intel_ddi.c
>+++ b/drivers/gpu/drm/i915/display/intel_ddi.c
>@@ -5295,6 +5295,9 @@ static enum hpd_pin cnl_hpd_pin(struct drm_i915_private *dev_priv,
> 	return HPD_PORT_A + port - PORT_A;
> }
>
>+#define port_tc_name(port) ((port) - PORT_TC1 + '1')
>+#define tc_port_name(tc_port) ((tc_port) - TC_PORT_1 + '1')

hopefully we won't have more than 10 ports. Also, not sure "_name" is
accurate since it's only the string version of the number. Maybe
port_tc_to_str()/tc_port_to_str() ?

either way,

Reviewed-by: Lucas De Marchi <lucas.demarchi at intel.com>

Lucas De Marchi

>+
> void intel_ddi_init(struct drm_i915_private *dev_priv, enum port port)
> {
> 	struct intel_digital_port *dig_port;
>@@ -5350,9 +5353,9 @@ void intel_ddi_init(struct drm_i915_private *dev_priv, enum port port)
> 				 DRM_MODE_ENCODER_TMDS,
> 				 "DDI %s%c/PHY %s%c",
> 				 port >= PORT_TC1 ? "TC" : "",
>-				 port >= PORT_TC1 ? port_name(port) : port - PORT_TC1 + '1',
>+				 port >= PORT_TC1 ? port_tc_name(port) : port_name(port),
> 				 tc_port != TC_PORT_NONE ? "TC" : "",
>-				 tc_port != TC_PORT_NONE ? phy_name(phy) : tc_port - TC_PORT_1 + '1');
>+				 tc_port != TC_PORT_NONE ? tc_port_name(tc_port) : phy_name(phy));
> 	} else if (INTEL_GEN(dev_priv) >= 11) {
> 		enum tc_port tc_port = intel_port_to_tc(dev_priv, port);
>
>@@ -5362,7 +5365,7 @@ void intel_ddi_init(struct drm_i915_private *dev_priv, enum port port)
> 				 port_name(port),
> 				 port >= PORT_C ? " (TC)" : "",
> 				 tc_port != TC_PORT_NONE ? "TC" : "",
>-				 tc_port != TC_PORT_NONE ? phy_name(phy) : tc_port - TC_PORT_1 + '1');
>+				 tc_port != TC_PORT_NONE ? tc_port_name(tc_port) : phy_name(phy));
> 	} else {
> 		drm_encoder_init(&dev_priv->drm, &encoder->base, &intel_ddi_funcs,
> 				 DRM_MODE_ENCODER_TMDS,
>-- 
>2.26.2
>
>_______________________________________________
>Intel-gfx mailing list
>Intel-gfx at lists.freedesktop.org
>https://lists.freedesktop.org/mailman/listinfo/intel-gfx


More information about the Intel-gfx mailing list