[Intel-gfx] [PATCH v2 00/19] drm/i915: Futher cleanup around hpd pins and port identfiers
Ville Syrjala
ville.syrjala at linux.intel.com
Fri Oct 23 13:34:01 UTC 2020
From: Ville Syrjälä <ville.syrjala at linux.intel.com>
Remainder of the latest hpd cleanup. Apart from rebasing I
didn't change much, except I did the s/TC_PORT_TC1/TC_PORT_1/
thing Lucas suggested.
Ville Syrjälä (19):
drm/i915: s/PORT_TC/TC_PORT_/
drm/i915: Add PORT_TCn aliases to enum port
drm/i915: Give DDI encoders even better names
drm/i915: Introduce AUX_CH_USBCn
drm/i915: Pimp AUX CH names
drm/i915: Use AUX_CH_USBCn for the RKL VBT AUX CH setup
drm/i915: Parametrize BXT_DE_PORT_HP_DDI with hpd_pin
drm/i915: Introduce GEN8_DE_PORT_HOTPLUG()
drm/i915: s/port/hpd_pin/ for icp+ ddi hpd bits
drm/i915: s/tc_port/hpd_pin/ in GEN11_{TC,TBT}_HOTPLUG()
drm/i915: s/tc_port/hpd_pin/ in icp+ TC hotplug bits
drm/i915: Relocate intel_hpd_{enabled,hotplug}_irqs()
drm/i915: Split gen11_hpd_detection_setup() into tc vs. tbt variants
drm/i915: Don't enable hpd detection logic from irq_postinstall()
drm/i915: Rename 'tmp_mask'
drm/i915: Remove the per-plaform IIR HPD masking
drm/i915: Enable hpd logic only for ports that are present
drm/i915: Use GEN3_IRQ_INIT() to init south interrupts in icp+
drm/i915: Get rid of ibx_irq_pre_postinstall()
drivers/gpu/drm/i915/display/intel_bios.c | 18 +-
drivers/gpu/drm/i915/display/intel_ddi.c | 31 +-
drivers/gpu/drm/i915/display/intel_display.c | 30 +-
drivers/gpu/drm/i915/display/intel_display.h | 30 +-
drivers/gpu/drm/i915/display/intel_dp.c | 66 ++-
drivers/gpu/drm/i915/display/intel_tc.c | 2 +-
drivers/gpu/drm/i915/gvt/display.c | 15 +-
drivers/gpu/drm/i915/i915_irq.c | 549 ++++++++++---------
drivers/gpu/drm/i915/i915_reg.h | 114 ++--
9 files changed, 493 insertions(+), 362 deletions(-)
--
2.26.2
More information about the Intel-gfx
mailing list