[Intel-gfx] [PATCH v6 11/11] drm/i915: Rename i915->gt to i915->gt0

Matt Roper matthew.d.roper at intel.com
Fri Dec 10 00:19:58 UTC 2021


On Thu, Dec 09, 2021 at 03:25:12PM +0200, Andi Shyti wrote:
> In preparation of the multitile support, highlight the root GT by
> calling it gt0 inside the drm i915 private data.
> 
> Signed-off-by: Andi Shyti <andi.shyti at linux.intel.com>
> Cc: Chris Wilson <chris at chris-wilson.co.uk>
> Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> Cc: Lucas De Marchi <lucas.demarchi at intel.com>
> Cc: Rodrigo Vivi <rodrigo.vivi at intel.com>
> Cc: Tvrtko Ursulin <tvrtko.ursulin at intel.com>

Reviewed-by: Matt Roper <matthew.d.roper at intel.com>

If you decide to not drop i915->ggtt completely in the previous patch,
we might want to make a simimlar naming change to that field as well.


Matt

> ---
>  drivers/gpu/drm/i915/i915_drv.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
> index 96e3553838ef..a4084f209097 100644
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -1008,7 +1008,7 @@ struct drm_i915_private {
>  	struct i915_perf perf;
>  
>  	/* Abstract the submission mechanism (legacy ringbuffer or execlists) away */
> -	struct intel_gt gt;
> +	struct intel_gt gt0;
>  
>  	struct {
>  		struct i915_gem_contexts {
> @@ -1082,7 +1082,7 @@ static inline struct drm_i915_private *pdev_to_i915(struct pci_dev *pdev)
>  
>  static inline struct intel_gt *to_gt(struct drm_i915_private *i915)
>  {
> -	return &i915->gt;
> +	return &i915->gt0;
>  }
>  
>  /* Simple iterator over all initialised engines */
> -- 
> 2.34.1
> 

-- 
Matt Roper
Graphics Software Engineer
VTT-OSGC Platform Enablement
Intel Corporation
(916) 356-2795


More information about the Intel-gfx mailing list