[Intel-gfx] [PATCH 16/23] drm/i915/intel_fb: Factor out calc_plane_normal_size()

Imre Deak imre.deak at intel.com
Thu Mar 11 17:47:25 UTC 2021


On Thu, Mar 11, 2021 at 07:26:42PM +0200, Ville Syrjälä wrote:
> On Thu, Mar 11, 2021 at 07:02:23PM +0200, Imre Deak wrote:
> > On Thu, Mar 11, 2021 at 06:52:26PM +0200, Ville Syrjälä wrote:
> > > On Thu, Mar 11, 2021 at 12:17:29AM +0200, Imre Deak wrote:
> > > > Factor out to a new function the logic to calculate an FB plane's
> > > > normal-view size.
> > > > 
> > > > Instead of using intel_remapped_plane_info, which is related only to
> > > > remapping, add a helper to get the tile pitch and rows for an FB plane,
> > > > so these helpers can be used both by the normal size calculation and the
> > > > remapping code.
> > > > 
> > > > Also add a new fb_plane_view_dims struct in which we can pass around the
> > > > view (either FB plane or plane source) and tile dimensions conveniently
> > > > to functions calculating further view parameters.
> > > > 
> > > > Signed-off-by: Imre Deak <imre.deak at intel.com>
> > > > ---
> > > >  drivers/gpu/drm/i915/display/intel_fb.c | 82 ++++++++++++++++++-------
> > > >  1 file changed, 61 insertions(+), 21 deletions(-)
> > > > 
> > > > diff --git a/drivers/gpu/drm/i915/display/intel_fb.c b/drivers/gpu/drm/i915/display/intel_fb.c
> > > > index 62a8e37dca38..f661b21b119d 100644
> > > > --- a/drivers/gpu/drm/i915/display/intel_fb.c
> > > > +++ b/drivers/gpu/drm/i915/display/intel_fb.c
> > > > @@ -634,6 +634,59 @@ static u32 setup_fb_rotation(int plane, const struct intel_remapped_plane_info *
> > > >  	return plane_info->width * plane_info->height;
> > > >  }
> > > >  
> > > > +struct fb_plane_view_dims {
> > > > +	unsigned int width, height;
> > > > +	unsigned int tile_width, tile_height;
> > > > +};
> > > > +
> > > > +static void init_plane_view_dims(const struct intel_framebuffer *fb, int color_plane,
> > > > +				 unsigned int width, unsigned int height,
> > > > +				 struct fb_plane_view_dims *dims)
> > > > +{
> > > > +	dims->width = width;
> > > > +	dims->height = height;
> > > > +
> > > > +	intel_tile_dims(&fb->base, color_plane, &dims->tile_width, &dims->tile_height);
> > > > +}
> > > > +
> > > > +static unsigned int plane_view_stride_tiles(const struct intel_framebuffer *fb, int color_plane,
> > > > +					    const struct fb_plane_view_dims *dims)
> > > > +{
> > > > +	const struct drm_framebuffer *drm_fb = &fb->base;
> > > > +
> > > > +	return DIV_ROUND_UP(drm_fb->pitches[color_plane],
> > > > +			    dims->tile_width * drm_fb->format->cpp[color_plane]);
> > > 
> > > plane_view_fb_stride_tiles() maybe to make it clear it's the fb stride
> > > we're talking about here?
> > 
> > Ok.
> > 
> > > > +}
> > > > +
> > > > +static unsigned int plane_view_tile_rows(const struct intel_framebuffer *fb, int color_plane,
> > > > +					 const struct fb_plane_view_dims *dims,
> > > > +					 int y)
> > > > +{
> > > > +	return DIV_ROUND_UP(y + dims->height, dims->tile_height);
> > > > +}
> > > > +
> > > > +static int calc_plane_normal_size(const struct intel_framebuffer *fb, int color_plane,
> > > > +				  const struct fb_plane_view_dims *dims,
> > > > +				  int x, int y)
> > > > +{
> > > > +	const struct drm_framebuffer *drm_fb = &fb->base;
> > > > +	struct drm_i915_private *i915 = to_i915(drm_fb->dev);
> > > > +	int pages;
> > > 
> > > 'tiles'?
> > 
> > Ok, not always pages.
> > 
> > > > +
> > > > +	if (is_surface_linear(drm_fb, color_plane)) {
> > > > +		unsigned int size;
> > > > +
> > > > +		size = (y + dims->height) * drm_fb->pitches[color_plane] +
> > > > +		       x * drm_fb->format->cpp[color_plane];
> > > > +		pages = DIV_ROUND_UP(size, intel_tile_size(i915));
> > > > +	} else {
> > > > +		pages = plane_view_stride_tiles(fb, color_plane, dims) *
> > > > +			plane_view_tile_rows(fb, color_plane, dims, y);
> > > > +	}
> > > > +
> > > > +	return pages;
> > > > +}
> > > > +
> > > >  int intel_fill_fb_info(struct drm_i915_private *i915, struct drm_framebuffer *fb)
> > > >  {
> > > >  	struct intel_framebuffer *intel_fb = to_intel_framebuffer(fb);
> > > > @@ -644,6 +697,7 @@ int intel_fill_fb_info(struct drm_i915_private *i915, struct drm_framebuffer *fb
> > > >  	unsigned int tile_size = intel_tile_size(i915);
> > > >  
> > > >  	for (i = 0; i < num_planes; i++) {
> > > > +		struct fb_plane_view_dims view_dims;
> > > >  		unsigned int width, height;
> > > >  		unsigned int cpp, size;
> > > >  		u32 offset;
> > > > @@ -669,6 +723,8 @@ int intel_fill_fb_info(struct drm_i915_private *i915, struct drm_framebuffer *fb
> > > >  		if (ret)
> > > >  			return ret;
> > > >  
> > > > +		init_plane_view_dims(intel_fb, i, width, height, &view_dims);
> > > > +
> > > >  		/*
> > > >  		 * First pixel of the framebuffer from
> > > >  		 * the start of the normal gtt mapping.
> > > > @@ -680,38 +736,22 @@ int intel_fill_fb_info(struct drm_i915_private *i915, struct drm_framebuffer *fb
> > > >  
> > > >  		if (!is_surface_linear(fb, i)) {
> > > >  			struct intel_remapped_plane_info plane_info;
> > > > -			unsigned int tile_width, tile_height;
> > > > -
> > > > -			intel_tile_dims(fb, i, &tile_width, &tile_height);
> > > >  
> > > >  			plane_info.offset = offset;
> > > > -			plane_info.stride = DIV_ROUND_UP(fb->pitches[i],
> > > > -							 tile_width * cpp);
> > > > -			plane_info.width = DIV_ROUND_UP(x + width, tile_width);
> > > > -			plane_info.height = DIV_ROUND_UP(y + height,
> > > > -							 tile_height);
> > > > -
> > > > -			/* how many tiles does this plane need */
> > > > -			size = plane_info.stride * plane_info.height;
> > > > -			/*
> > > > -			 * If the plane isn't horizontally tile aligned,
> > > > -			 * we need one more tile.
> > > > -			 */
> > > > -			if (x != 0)
> > > > -				size++;
> > > 
> > > Where did that go?
> > 
> > Arg, thanks for catching it.
> > 
> > > > +			plane_info.stride = plane_view_stride_tiles(intel_fb, i, &view_dims);
> > > > +			plane_info.width = DIV_ROUND_UP(x + width, view_dims.tile_width);
> > > 
> > > Why this doesn't have its own function?
> > 
> > Can move it to a plane_view_fb_width_tiles() helper (and maybe also
> > s/plane_view_tile_rows/plane_view_fb_height_tiles).
> 
> Well. those are the view width/height no? So I would not put the "fb" in
> the name there.

Ah, right.

Btw just realized that later in the patchset I rename
plane_view_stride_tiles() to plane_view_src_stride_tiles() and add
plane_view_dst_stride_tiles(), are you ok with that instead?

> 
> > 
> > > 
> > > > +			plane_info.height = plane_view_tile_rows(intel_fb, i, &view_dims, y);
> > > >  
> > > >  			gtt_offset_rotated +=
> > > >  				setup_fb_rotation(i, &plane_info,
> > > >  						  gtt_offset_rotated,
> > > >  						  x, y, width, height,
> > > >  						  tile_size,
> > > > -						  tile_width, tile_height,
> > > > +						  view_dims.tile_width, view_dims.tile_height,
> > > >  						  fb);
> > > > -		} else {
> > > > -			size = DIV_ROUND_UP((y + height) * fb->pitches[i] +
> > > > -					    x * cpp, tile_size);
> > > >  		}
> > > >  
> > > > +		size = calc_plane_normal_size(intel_fb, i, &view_dims, x, y);
> > > >  		/* how many tiles in total needed in the bo */
> > > >  		max_size = max(max_size, offset + size);
> > > >  	}
> > > > -- 
> > > > 2.25.1
> > > > 
> > > > _______________________________________________
> > > > Intel-gfx mailing list
> > > > Intel-gfx at lists.freedesktop.org
> > > > https://lists.freedesktop.org/mailman/listinfo/intel-gfx
> > > 
> > > -- 
> > > Ville Syrjälä
> > > Intel
> 
> -- 
> Ville Syrjälä
> Intel


More information about the Intel-gfx mailing list