[Intel-gfx] [PATCH v2 0/8] drm/edid: overhaul displayid iterator
Jani Nikula
jani.nikula at intel.com
Mon Mar 29 13:37:14 UTC 2021
v2 of [1], addressing Ville's review comments, and adding a couple of
extra patches on top.
BR,
Jani.
[1] https://patchwork.freedesktop.org/series/87802/
Jani Nikula (8):
drm/edid: make a number of functions, parameters and variables const
drm/displayid: add separate drm_displayid.c
drm/displayid: add new displayid section/block iterators
drm/edid: use the new displayid iterator for detailed modes
drm/edid: use the new displayid iterator for finding CEA extension
drm/edid: use the new displayid iterator for tile info
drm/displayid: allow data blocks with 0 payload length
drm/displayid: rename displayid_hdr to displayid_header
drivers/gpu/drm/Makefile | 2 +-
drivers/gpu/drm/drm_displayid.c | 132 ++++++++++++++++++++++++
drivers/gpu/drm/drm_edid.c | 171 +++++++-------------------------
include/drm/drm_displayid.h | 30 ++++--
include/drm/drm_edid.h | 3 +
5 files changed, 196 insertions(+), 142 deletions(-)
create mode 100644 drivers/gpu/drm/drm_displayid.c
--
2.20.1
More information about the Intel-gfx
mailing list