[Intel-gfx] [PATCH 1/2] drm/dp: add drm_dp_phy_name() for getting DP PHY name

Ville Syrjälä ville.syrjala at linux.intel.com
Tue Oct 5 08:23:55 UTC 2021


On Tue, Oct 05, 2021 at 11:10:52AM +0300, Jani Nikula wrote:
> Add a helper for getting the DP PHY name. In the interest of caller
> simplicity and to avoid allocations and passing in of buffers, duplicate
> the const strings to return. It's a minor penalty to pay for simplicity
> in all the call sites.

Yeah, the on stack extra buffer is getting a bit annoying, especially
with the calls multiplying like rabbits in my recent patches.

Series is
Reviewed-by: Ville Syrjälä <ville.syrjala at linux.intel.com>

> 
> Cc: Ville Syrjälä <ville.syrjala at linux.intel.com>
> Signed-off-by: Jani Nikula <jani.nikula at intel.com>
> ---
>  drivers/gpu/drm/drm_dp_helper.c | 21 +++++++++++++++++++++
>  include/drm/drm_dp_helper.h     |  2 ++
>  2 files changed, 23 insertions(+)
> 
> diff --git a/drivers/gpu/drm/drm_dp_helper.c b/drivers/gpu/drm/drm_dp_helper.c
> index 4d0d1e8e51fa..f1d03b5a4bab 100644
> --- a/drivers/gpu/drm/drm_dp_helper.c
> +++ b/drivers/gpu/drm/drm_dp_helper.c
> @@ -197,6 +197,27 @@ void drm_dp_link_train_channel_eq_delay(const struct drm_dp_aux *aux,
>  }
>  EXPORT_SYMBOL(drm_dp_link_train_channel_eq_delay);
>  
> +const char *drm_dp_phy_name(enum drm_dp_phy dp_phy)
> +{
> +	static const char * const phy_names[] = {
> +		[DP_PHY_DPRX] = "DPRX",
> +		[DP_PHY_LTTPR1] = "LTTPR 1",
> +		[DP_PHY_LTTPR2] = "LTTPR 2",
> +		[DP_PHY_LTTPR3] = "LTTPR 3",
> +		[DP_PHY_LTTPR4] = "LTTPR 4",
> +		[DP_PHY_LTTPR5] = "LTTPR 5",
> +		[DP_PHY_LTTPR6] = "LTTPR 6",
> +		[DP_PHY_LTTPR7] = "LTTPR 7",
> +		[DP_PHY_LTTPR8] = "LTTPR 8",
> +	};
> +
> +	if (dp_phy < 0 || dp_phy >= ARRAY_SIZE(phy_names))
> +		return "<INVALID DP PHY>";
> +
> +	return phy_names[dp_phy];
> +}
> +EXPORT_SYMBOL(drm_dp_phy_name);
> +
>  void drm_dp_lttpr_link_train_clock_recovery_delay(void)
>  {
>  	usleep_range(100, 200);
> diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h
> index b52df4db3e8f..c873e6349b41 100644
> --- a/include/drm/drm_dp_helper.h
> +++ b/include/drm/drm_dp_helper.h
> @@ -2115,6 +2115,8 @@ bool drm_dp_read_sink_count_cap(struct drm_connector *connector,
>  				const struct drm_dp_desc *desc);
>  int drm_dp_read_sink_count(struct drm_dp_aux *aux);
>  
> +const char *drm_dp_phy_name(enum drm_dp_phy dp_phy);
> +
>  int drm_dp_read_lttpr_common_caps(struct drm_dp_aux *aux,
>  				  u8 caps[DP_LTTPR_COMMON_CAP_SIZE]);
>  int drm_dp_read_lttpr_phy_caps(struct drm_dp_aux *aux,
> -- 
> 2.30.2

-- 
Ville Syrjälä
Intel


More information about the Intel-gfx mailing list