[Intel-gfx] [PATCH 07/11] drm/i915: Add i915_gem_context_is_full_ppgtt

Bloomfield, Jon jon.bloomfield at intel.com
Thu Sep 2 17:05:05 UTC 2021


> -----Original Message-----
> From: Tvrtko Ursulin <tvrtko.ursulin at linux.intel.com>
> Sent: Thursday, September 2, 2021 9:42 AM
> To: Daniel Vetter <daniel at ffwll.ch>
> Cc: Daniel Vetter <daniel.vetter at ffwll.ch>; DRI Development <dri-
> devel at lists.freedesktop.org>; Intel Graphics Development <intel-
> gfx at lists.freedesktop.org>; Maarten Lankhorst
> <maarten.lankhorst at linux.intel.com>; Vetter, Daniel
> <daniel.vetter at intel.com>; Bloomfield, Jon <jon.bloomfield at intel.com>;
> Chris Wilson <chris at chris-wilson.co.uk>; Joonas Lahtinen
> <joonas.lahtinen at linux.intel.com>; Thomas Hellström
> <thomas.hellstrom at linux.intel.com>; Auld, Matthew
> <matthew.auld at intel.com>; Landwerlin, Lionel G
> <lionel.g.landwerlin at intel.com>; Dave Airlie <airlied at redhat.com>; Jason
> Ekstrand <jason at jlekstrand.net>
> Subject: Re: [Intel-gfx] [PATCH 07/11] drm/i915: Add
> i915_gem_context_is_full_ppgtt
> 
> 
> On 02/09/2021 16:22, Daniel Vetter wrote:
> > On Thu, Sep 02, 2021 at 03:54:36PM +0100, Tvrtko Ursulin wrote:
> >> On 02/09/2021 15:20, Daniel Vetter wrote:
> >>> And use it anywhere we have open-coded checks for ctx->vm that really
> >>> only check for full ppgtt.
> >>>
> >>> Plus for paranoia add a GEM_BUG_ON that checks it's really only set
> >>> when we have full ppgtt, just in case. gem_context->vm is different
> >>> since it's NULL in ggtt mode, unlike intel_context->vm or gt->vm,
> >>> which is always set.
> >>>
> >>> v2: 0day found a testcase that I missed.
> >>>
> >>> Reviewed-by: Maarten Lankhorst <maarten.lankhorst at linux.intel.com>
> >>> Signed-off-by: Daniel Vetter <daniel.vetter at intel.com>
> >>> Cc: Jon Bloomfield <jon.bloomfield at intel.com>
> >>> Cc: Chris Wilson <chris at chris-wilson.co.uk>
> >>> Cc: Maarten Lankhorst <maarten.lankhorst at linux.intel.com>
> >>> Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> >>> Cc: Daniel Vetter <daniel.vetter at ffwll.ch>
> >>> Cc: "Thomas Hellström" <thomas.hellstrom at linux.intel.com>
> >>> Cc: Matthew Auld <matthew.auld at intel.com>
> >>> Cc: Lionel Landwerlin <lionel.g.landwerlin at intel.com>
> >>> Cc: Dave Airlie <airlied at redhat.com>
> >>> Cc: Jason Ekstrand <jason at jlekstrand.net>
> >>> ---
> >>>    drivers/gpu/drm/i915/gem/i915_gem_context.c           | 2 +-
> >>>    drivers/gpu/drm/i915/gem/i915_gem_context.h           | 7 +++++++
> >>>    drivers/gpu/drm/i915/gem/i915_gem_execbuffer.c        | 2 +-
> >>>    drivers/gpu/drm/i915/gem/selftests/i915_gem_context.c | 6 +++---
> >>>    4 files changed, 12 insertions(+), 5 deletions(-)
> >>>
> >>> diff --git a/drivers/gpu/drm/i915/gem/i915_gem_context.c
> b/drivers/gpu/drm/i915/gem/i915_gem_context.c
> >>> index 7a566fb7cca4..1eec85944c1f 100644
> >>> --- a/drivers/gpu/drm/i915/gem/i915_gem_context.c
> >>> +++ b/drivers/gpu/drm/i915/gem/i915_gem_context.c
> >>> @@ -1566,7 +1566,7 @@ static int get_ppgtt(struct
> drm_i915_file_private *file_priv,
> >>>    	int err;
> >>>    	u32 id;
> >>> -	if (!rcu_access_pointer(ctx->vm))
> >>> +	if (!i915_gem_context_is_full_ppgtt(ctx))
> >>
> >> It reads a bit wrong because GEM context cannot *be* full ppggt. It can
> be
> >> associated with a VM which is or isn't full ppgtt. So a test on a VM
> >> retrieved from a context is semnntically more correct. Perhaps you want
> to
> >> consider adding a helper to that effect instead? It could mean splitting
> >> into two helpers (getter + test) or maybe just renaming would work. Like
> >> i915_gem_context_has_full_ppgtt_vm(ctx)?
> >
> > The pointer isn't set when the driver/context isn't running in full ppgtt
> > mode. This is why I've added the GEM_BUG_ON to check we're not
> breaking
> > any invariants. So yeah it is a full ppgtt context or it's not, that is
> > indeed the question here.
> >
> > I'm happy to bikeshed the naming, but I don't see how your suggestion is
> > an improvement.
> 
> I think the pointer being set or not is implementation detail, for
> instance we could have it always set just like it is in intel_context.
> 
> I simply think GEM context *isn't* full ppgtt, but the VM is. And since
> GEM context *points* to a VM, *has* is the right verb in my mind. You
> did not write why do you not see has as more correct than is so I don't
> want to be guessing too much.

FWIW, I agree with Tvrtko. i915_gem_context_is_full_ppgtt is incorrect grammar. It IS a bike shed, but, hey it'll live for a while.



More information about the Intel-gfx mailing list