[Intel-gfx] [PATCH 0/8] drm/i915: Move power well code to a separate file

Imre Deak imre.deak at intel.com
Tue Feb 22 16:51:29 UTC 2022

This is the first half of patchset [1], rebased on drm-tip and adding
the R-b tags from Jouni. I'll send the second half separately as that
needs a minor change and it's worth having a separate CI test result for
the changes there (convert the u64 domain to a bitmap, sanitize the
port/aux_ch->power domain mappings).

[1] https://patchwork.freedesktop.org/series/99476/

Cc: Jouni Högander <jouni.hogander at intel.com>

Imre Deak (8):
  drm/i915: Fix the VDSC_PW2 power domain enum value
  drm/i915: Sanitize open-coded power well enable()/disable() calls
  drm/i915: Remove redundant state verification during TypeC AUX power
    well disabling
  drm/i915: Move i915_power_well_regs struct into i915_power_well_ops
  drm/i915: Move power well get/put/enable/disable functions to a new
  drm/i915: Add function to call a power well's sync_hw() hook
  drm/i915: Add functions to get a power well's
  drm/i915: Move intel_display_power_well_is_enabled() to

 drivers/gpu/drm/i915/Makefile                 |   1 +
 .../drm/i915/display/intel_display_debugfs.c  |   1 +
 .../drm/i915/display/intel_display_power.c    | 521 ++++--------------
 .../drm/i915/display/intel_display_power.h    |  37 +-
 .../i915/display/intel_display_power_well.c   | 113 ++++
 .../i915/display/intel_display_power_well.h   | 153 +++++
 drivers/gpu/drm/i915/display/intel_hdcp.c     |   1 +
 7 files changed, 386 insertions(+), 441 deletions(-)
 create mode 100644 drivers/gpu/drm/i915/display/intel_display_power_well.c
 create mode 100644 drivers/gpu/drm/i915/display/intel_display_power_well.h


More information about the Intel-gfx mailing list