[Intel-gfx] [PATCH RESEND] drm/i915/dp: make intel_dp_pack_aux() static again

Ville Syrjälä ville.syrjala at linux.intel.com
Wed Jan 12 13:57:53 UTC 2022


On Wed, Jan 12, 2022 at 12:57:03PM +0200, Jani Nikula wrote:
> The last user of intel_dp_pack_aux() outside intel_dp_aux.c got removed
> in commit ad26451a7902 ("drm/i915/display: Drop PSR support from HSW and
> BDW"). Make the function static again.
> 
> Rename the pack/unpack functions to follow the usual naming conventions
> while at it.
> 
> Signed-off-by: Jani Nikula <jani.nikula at intel.com>

Reviewed-by: Ville Syrjälä <ville.syrjala at linux.intel.com>

> ---
>  drivers/gpu/drm/i915/display/intel_dp_aux.c | 8 ++++----
>  drivers/gpu/drm/i915/display/intel_dp_aux.h | 4 ----
>  2 files changed, 4 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/display/intel_dp_aux.c b/drivers/gpu/drm/i915/display/intel_dp_aux.c
> index 5fbb767fcd63..2bc119374555 100644
> --- a/drivers/gpu/drm/i915/display/intel_dp_aux.c
> +++ b/drivers/gpu/drm/i915/display/intel_dp_aux.c
> @@ -10,7 +10,7 @@
>  #include "intel_pps.h"
>  #include "intel_tc.h"
>  
> -u32 intel_dp_pack_aux(const u8 *src, int src_bytes)
> +static u32 intel_dp_aux_pack(const u8 *src, int src_bytes)
>  {
>  	int i;
>  	u32 v = 0;
> @@ -22,7 +22,7 @@ u32 intel_dp_pack_aux(const u8 *src, int src_bytes)
>  	return v;
>  }
>  
> -static void intel_dp_unpack_aux(u32 src, u8 *dst, int dst_bytes)
> +static void intel_dp_aux_unpack(u32 src, u8 *dst, int dst_bytes)
>  {
>  	int i;
>  
> @@ -267,7 +267,7 @@ intel_dp_aux_xfer(struct intel_dp *intel_dp,
>  			for (i = 0; i < send_bytes; i += 4)
>  				intel_uncore_write(uncore,
>  						   ch_data[i >> 2],
> -						   intel_dp_pack_aux(send + i,
> +						   intel_dp_aux_pack(send + i,
>  								     send_bytes - i));
>  
>  			/* Send the command and wait for it to complete */
> @@ -352,7 +352,7 @@ intel_dp_aux_xfer(struct intel_dp *intel_dp,
>  		recv_bytes = recv_size;
>  
>  	for (i = 0; i < recv_bytes; i += 4)
> -		intel_dp_unpack_aux(intel_uncore_read(uncore, ch_data[i >> 2]),
> +		intel_dp_aux_unpack(intel_uncore_read(uncore, ch_data[i >> 2]),
>  				    recv + i, recv_bytes - i);
>  
>  	ret = recv_bytes;
> diff --git a/drivers/gpu/drm/i915/display/intel_dp_aux.h b/drivers/gpu/drm/i915/display/intel_dp_aux.h
> index 4afbe76217b9..738577537bc7 100644
> --- a/drivers/gpu/drm/i915/display/intel_dp_aux.h
> +++ b/drivers/gpu/drm/i915/display/intel_dp_aux.h
> @@ -6,12 +6,8 @@
>  #ifndef __INTEL_DP_AUX_H__
>  #define __INTEL_DP_AUX_H__
>  
> -#include <linux/types.h>
> -
>  struct intel_dp;
>  
> -u32 intel_dp_pack_aux(const u8 *src, int src_bytes);
> -
>  void intel_dp_aux_fini(struct intel_dp *intel_dp);
>  void intel_dp_aux_init(struct intel_dp *intel_dp);
>  
> -- 
> 2.30.2

-- 
Ville Syrjälä
Intel


More information about the Intel-gfx mailing list