[Intel-gfx] [PATCH v3 01/11] drm/i915: Move display and media IP version to runtime info
Michal Wajdeczko
michal.wajdeczko at intel.com
Thu Sep 1 09:14:08 UTC 2022
On 01.09.2022 09:45, Jani Nikula wrote:
> On Wed, 31 Aug 2022, Radhakrishna Sripada <radhakrishna.sripada at intel.com> wrote:
...
>> struct ip_version graphics;
>> + struct ip_version media;
>> + struct ip_version display;
>
> The runtime display info is now in an unnamed struct under struct
> intel_runtime_info below, and this belongs there.
>
> There's also some pressure to name it, and "display" would be the name,
> so this would collide.
>
> Seems like all of the above are overly generic names, including the
> pre-existing "graphics". Something to consider.
maybe
struct {
struct {
struct ip_version version;
...
} graphics;
struct {
struct ip_version version;
...
} media;
struct {
struct ip_version version;
...
} display;
} runtime;
then
drm_printf(p, "display version: %u.%02u\n",
runtime->display.version.ver,
runtime->display.version.rel);
...
Michal
More information about the Intel-gfx
mailing list