[Intel-gfx] [PATCH 1/6] drm/i915/display: Add support for global histogram
Murthy, Arun R
arun.r.murthy at intel.com
Tue Jun 20 08:44:56 UTC 2023
> -----Original Message-----
> From: Jani Nikula <jani.nikula at linux.intel.com>
> Sent: Tuesday, May 23, 2023 3:40 PM
> To: Murthy, Arun R <arun.r.murthy at intel.com>; intel-
> gfx at lists.freedesktop.org
> Subject: Re: [Intel-gfx] [PATCH 1/6] drm/i915/display: Add support for global
> histogram
>
> On Thu, 18 May 2023, Arun R Murthy <arun.r.murthy at intel.com> wrote:
> > API are added to enable/disable histogram. Upon generation of
> > histogram interrupt its notified to the usespace. User can then use
> > this histogram and generate a LUT which is then fed back to the
> enahancement block.
> > Histogram is an image statistics based on the input pixel stream.
> > LUT is a look up table consisiting of pixel data.
>
> Where's the corresponding userspace?
>
> See Documentation/gpu/drm-uapi.rst under "Open-Source Userspace
> Requirements".
>
Will be posting info on the user space component very soon.
> > Signed-off-by: Arun R Murthy <arun.r.murthy at intel.com>
> > ---
> > drivers/gpu/drm/i915/Makefile | 1 +
> > .../drm/i915/display/intel_display_types.h | 3 +
> > .../gpu/drm/i915/display/intel_global_hist.c | 295
> > ++++++++++++++++++ .../gpu/drm/i915/display/intel_global_hist.h |
> > 117 +++++++
> > 4 files changed, 416 insertions(+)
> > create mode 100644 drivers/gpu/drm/i915/display/intel_global_hist.c
> > create mode 100644 drivers/gpu/drm/i915/display/intel_global_hist.h
> >
> > diff --git a/drivers/gpu/drm/i915/Makefile
> > b/drivers/gpu/drm/i915/Makefile index 5ab909ec24e5..eac1e0d7bd30
> > 100644
> > --- a/drivers/gpu/drm/i915/Makefile
> > +++ b/drivers/gpu/drm/i915/Makefile
> > @@ -295,6 +295,7 @@ i915-y += \
> > display/intel_dpll.o \
> > display/intel_dpll_mgr.o \
> > display/intel_dpt.o \
> > + display/intel_global_hist.o \
>
> Comment near the top of the Makefile:
>
> # Please keep these build lists sorted!
>
> Also, I'm not sure "global hist" is a good name.
The hardware block is named as histogram block and enhancement block. Hence the name global histogram. A short form of this global_hist!
Any other inputs on the naming convention?
Thanks and Regards,
Arun R Murthy
--------------------
More information about the Intel-gfx
mailing list