[Intel-gfx] [PATCH v12 18/24] vfio: Add VFIO_DEVICE_BIND_IOMMUFD
Jason Gunthorpe
jgg at nvidia.com
Wed Jun 28 14:34:14 UTC 2023
On Mon, Jun 26, 2023 at 02:51:29PM +0000, Liu, Yi L wrote:
> > > >
> > > > Ah, any suggestion on the naming? How about vfio_device_get_kvm_safe_locked()?
> > >
> > > I thought you were using _df_ now for these functions?
> > >
> >
> > I see. Your point is passing df to _vfio_device_get_kvm_safe(() and
> > test the df->kvm within it. Hence rename it to be _df_. I think group
> > path should be ok with this change as well. Let me make it.
>
> To pass vfio_device_file to _vfio_device_get_kvm_safe(), needs to make
> the below changes to the group path. If just wants to test null kvm in the
> _vfio_device_get_kvm_safe(), maybe simpler to keep the current parameters
> and just move the null kvm test within this function. Is it?
This does seem a bit nicer, yes
> diff --git a/drivers/vfio/vfio_main.c b/drivers/vfio/vfio_main.c
> index 8a9ebcc6980b..4e6ea2943d28 100644
> --- a/drivers/vfio/vfio_main.c
> +++ b/drivers/vfio/vfio_main.c
> @@ -373,14 +373,22 @@ void vfio_unregister_group_dev(struct vfio_device *device)
> EXPORT_SYMBOL_GPL(vfio_unregister_group_dev);
>
> #ifdef CONFIG_HAVE_KVM
> -void _vfio_device_get_kvm_safe(struct vfio_device *device, struct kvm *kvm)
> +void _vfio_df_get_kvm_safe(struct vfio_device_file *df)
But still avoid the leading _ here
Jason
More information about the Intel-gfx
mailing list