[Intel-gfx] [PATCH v12 3/6] drm/i915/hdcp: HDCP2.x Refactoring to agnostic hdcp
Shankar, Uma
uma.shankar at intel.com
Thu Mar 16 08:00:54 UTC 2023
> -----Original Message-----
> From: Kandpal, Suraj <suraj.kandpal at intel.com>
> Sent: Thursday, March 9, 2023 1:24 PM
> To: intel-gfx at lists.freedesktop.org
> Cc: Nautiyal, Ankit K <ankit.k.nautiyal at intel.com>; Shankar, Uma
> <uma.shankar at intel.com>; Kandpal, Suraj <suraj.kandpal at intel.com>; Winkler,
> Tomas <tomas.winkler at intel.com>; Vivi, Rodrigo <rodrigo.vivi at intel.com>; Gupta,
> Anshuman <anshuman.gupta at intel.com>
> Subject: [PATCH v12 3/6] drm/i915/hdcp: HDCP2.x Refactoring to agnostic hdcp
>
> As now we have more then one type of content protection secrity firmware.
Just say it as "There are more than type of content protection security firmware.
Make the name generic". Also typo in security.
With this fixed,
Reviewed-by: Uma Shankar <uma.shankar at intel.com>
> %s/_mei_/_
>
> --v3
> -Changing names to drop cp_fw to make naming more agnostic[Jani]
>
> --v4
> -remove header reference in intel_display_core.h [Uma] -fix commit message and
> prefix drm [Uma]
>
> Cc: Tomas Winkler <tomas.winkler at intel.com>
> Cc: Rodrigo Vivi <rodrigo.vivi at intel.com>
> Cc: Uma Shankar <uma.shankar at intel.com>
> Cc: Ankit Nautiyal <ankit.k.nautiyal at intel.com>
> Signed-off-by: Anshuman Gupta <anshuman.gupta at intel.com>
> Signed-off-by: Suraj Kandpal <suraj.kandpal at intel.com>
> Reviewed-by: Ankit Nautiyal <ankit.k.nautiyal at intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_hdcp.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_hdcp.c
> b/drivers/gpu/drm/i915/display/intel_hdcp.c
> index 1ae0882dc1d4..3b9bdc4a764d 100644
> --- a/drivers/gpu/drm/i915/display/intel_hdcp.c
> +++ b/drivers/gpu/drm/i915/display/intel_hdcp.c
> @@ -1409,7 +1409,7 @@ static int hdcp2_authenticate_port(struct intel_connector
> *connector)
> return ret;
> }
>
> -static int hdcp2_close_mei_session(struct intel_connector *connector)
> +static int hdcp2_close_session(struct intel_connector *connector)
> {
> struct intel_digital_port *dig_port = intel_attached_dig_port(connector);
> struct drm_i915_private *dev_priv = to_i915(connector->base.dev); @@ -
> 1433,7 +1433,7 @@ static int hdcp2_close_mei_session(struct intel_connector
> *connector)
>
> static int hdcp2_deauthenticate_port(struct intel_connector *connector) {
> - return hdcp2_close_mei_session(connector);
> + return hdcp2_close_session(connector);
> }
>
> /* Authentication flow starts from here */
> --
> 2.25.1
More information about the Intel-gfx
mailing list