[Intel-gfx] [PATCH v13 0/6] Enable HDCP2.x via GSC CS
Shankar, Uma
uma.shankar at intel.com
Thu Mar 23 06:55:20 UTC 2023
> -----Original Message-----
> From: Kandpal, Suraj <suraj.kandpal at intel.com>
> Sent: Thursday, March 16, 2023 2:59 PM
> To: intel-gfx at lists.freedesktop.org
> Cc: Nautiyal, Ankit K <ankit.k.nautiyal at intel.com>; Shankar, Uma
> <uma.shankar at intel.com>; Kandpal, Suraj <suraj.kandpal at intel.com>
> Subject: [PATCH v13 0/6] Enable HDCP2.x via GSC CS
>
> These patches enable HDCP2.x on machines MTL and above.
> From MTL onwards CSME is spilt into GSC and CSC and now we use GSC CS instead of
> MEI to talk to firmware to start HDCP authentication
Pushed the series to drm-intel-next. Thanks for the patches and reviews.
Some follow-up work is expected, which Suraj promised to work on along
with community.
Regards,
Uma Shankar
> --v2
> -Fixing some checkpatch changes which I forgot before sending out the series
>
> --v3
> -Drop cp and fw to make naming more agnostic[Jani] -Sort header[Jani] -remove
> static inline function from i915_hdcp_interface[Jani] -abstract DISPLAY_VER
> check[Jani]
>
> --v4
> -Remove stale comment P2 [Jani]
> -Fix part where file rename looks like its removed in P2 and added in P3 [Jani] -Add
> bitmask definition for host session id[Alan] -Seprating gsc load and heci cmd
> submission into different funcs[Alan] -Create comman function to fill
> gsc_mtl_header[Alan]
>
> --v5
> -No need to make hdcp_message field null as we use kzalloc [Alan] -use i915->drm
> instead of gt->i915->drm [Alan]
>
> --v6
> -Make each patch build individually [Jani] -drop cp_fw stale commit subject [Jani] -fix
> the date on license [Jani] -revert back to orginal design where mei and gsc fill their
> own header
>
> --v7
> -remove RB by Ankit
>
> --v8
> -change design to allocate and deallocate hdcp_message only at enablement and
> disabling of hdcp [Alan] -fix few formatting issue [Ankit] -fix stale comments [Ankit]
>
> --v9
> -move allocation dealloc of hdcp messgae to init and teardown [Alan] -remove obj
> from hdcp message , use i915_vma_unpin_and_release [Alan] -remove return
> statement from intel_hdcp_gsc_fini [Ankit]
>
> --v10
> -remove unnecessary i915_vma_unpin [Alan]
>
> --v11
> -commit message and header fix [Uma]
> -comment style fix [Uma]
> -add line gap [Uma]
>
> --v12
> -rename comp to arbiter [Uma]
>
>
>
> Anshuman Gupta (1):
> drm/i915/hdcp: Use generic names for HDCP helpers and structs
>
> Suraj Kandpal (5):
> drm/i915/gsc: Create GSC request submission mechanism
> drm/i915/hdcp: HDCP2.x Refactoring to agnostic hdcp
> drm/i915/hdcp: Refactor HDCP API structures
> drm/i915/mtl: Add function to send command to GSC CS
> drm/i915/mtl: Add HDCP GSC interface
>
> drivers/gpu/drm/i915/Makefile | 2 +
> .../gpu/drm/i915/display/intel_display_core.h | 8 +-
> .../drm/i915/display/intel_display_types.h | 2 +-
> drivers/gpu/drm/i915/display/intel_hdcp.c | 158 ++--
> drivers/gpu/drm/i915/display/intel_hdcp_gsc.c | 831 ++++++++++++++++++
> drivers/gpu/drm/i915/display/intel_hdcp_gsc.h | 26 +
> drivers/gpu/drm/i915/gt/intel_gpu_commands.h | 2 +
> .../i915/gt/uc/intel_gsc_uc_heci_cmd_submit.c | 109 +++
> .../i915/gt/uc/intel_gsc_uc_heci_cmd_submit.h | 61 ++
> drivers/misc/mei/hdcp/mei_hdcp.c | 105 ++-
> drivers/misc/mei/hdcp/mei_hdcp.h | 354 --------
> include/drm/i915_hdcp_interface.h | 539 ++++++++++++
> include/drm/i915_mei_hdcp_interface.h | 184 ----
> 13 files changed, 1718 insertions(+), 663 deletions(-) create mode 100644
> drivers/gpu/drm/i915/display/intel_hdcp_gsc.c
> create mode 100644 drivers/gpu/drm/i915/display/intel_hdcp_gsc.h
> create mode 100644 drivers/gpu/drm/i915/gt/uc/intel_gsc_uc_heci_cmd_submit.c
> create mode 100644 drivers/gpu/drm/i915/gt/uc/intel_gsc_uc_heci_cmd_submit.h
> create mode 100644 include/drm/i915_hdcp_interface.h delete mode 100644
> include/drm/i915_mei_hdcp_interface.h
>
> --
> 2.25.1
More information about the Intel-gfx
mailing list