[PATCH 0/8] drm/i915 & drm/xe: shared PCI ID macros

Jani Nikula jani.nikula at intel.com
Mon Sep 2 17:13:59 UTC 2024


There's considerable overlap in i915 and xe PCI ID macros, and (as can
be seen in this series) they get updated out of sync. With i915 display
continuing to use PCI IDs for platforms that i915 core does not support,
but xe does, the duplication will just increase. Just use a single file
for all of them.

BR,
Jani.

Jani Nikula (8):
  drm/i915/pciids: use designated initializers in INTEL_VGA_DEVICE()
  drm/i915/pciids: separate ARL and MTL PCI IDs
  drm/xe/pciids: add some missing ADL-N PCI IDs
  drm/xe/pciids: separate RPL-U and RPL-P PCI IDs
  drm/xe/pciids: separate ARL and MTL PCI IDs
  drm/i915/pciids: add PVC PCI ID macros
  drm/intel/pciids: rename i915_pciids.h to just pciids.h
  drm/xe: switch to common PCI ID macros

 arch/x86/kernel/early-quirks.c                |   2 +-
 .../drm/i915/display/intel_display_device.c   |   3 +-
 drivers/gpu/drm/i915/i915_pci.c               |   3 +-
 drivers/gpu/drm/i915/intel_device_info.c      |   2 +-
 drivers/gpu/drm/xe/xe_pci.c                   |  49 ++--
 include/drm/intel/{i915_pciids.h => pciids.h} |  63 ++---
 include/drm/intel/xe_pciids.h                 | 218 ------------------
 7 files changed, 64 insertions(+), 276 deletions(-)
 rename include/drm/intel/{i915_pciids.h => pciids.h} (96%)
 delete mode 100644 include/drm/intel/xe_pciids.h

-- 
2.39.2



More information about the Intel-gfx mailing list