[Intel-xe] [PATCH] drm/xe: Rename intel_de.h to xe_de.h

Thomas Hellström thomas.hellstrom at linux.intel.com
Thu Mar 23 09:22:44 UTC 2023


On 3/23/23 09:50, Maarten Lankhorst wrote:
> Rename intel_de.h to xe_de.h in order to remove #include_next,
> and change the ifdef guard to be the same as the rest of xe headers.
>
> This is consistent with the other files that are inside xe/display,
> and implement xe specific behavior.
>
> Signed-off-by: Maarten Lankhorst <maarten.lankhorst at linux.intel.com>

Reviewed-by: Thomas Hellström <thomas.hellstrom at linux.intel.com>


> ---
>   drivers/gpu/drm/i915/display/intel_de.h            | 2 +-
>   drivers/gpu/drm/xe/display/{intel_de.h => xe_de.h} | 8 ++++----
>   2 files changed, 5 insertions(+), 5 deletions(-)
>   rename drivers/gpu/drm/xe/display/{intel_de.h => xe_de.h} (97%)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_de.h b/drivers/gpu/drm/i915/display/intel_de.h
> index 5c223ff6b3ec..267b1108abbb 100644
> --- a/drivers/gpu/drm/i915/display/intel_de.h
> +++ b/drivers/gpu/drm/i915/display/intel_de.h
> @@ -4,7 +4,7 @@
>    */
>   
>   #ifdef BUILD_FOR_XE
> -#include_next "intel_de.h"
> +#include "xe_de.h"
>   #else
>   #ifndef __INTEL_DE_H__
>   #define __INTEL_DE_H__
> diff --git a/drivers/gpu/drm/xe/display/intel_de.h b/drivers/gpu/drm/xe/display/xe_de.h
> similarity index 97%
> rename from drivers/gpu/drm/xe/display/intel_de.h
> rename to drivers/gpu/drm/xe/display/xe_de.h
> index 0d0504b483ef..9f92fdb4159a 100644
> --- a/drivers/gpu/drm/xe/display/intel_de.h
> +++ b/drivers/gpu/drm/xe/display/xe_de.h
> @@ -1,10 +1,10 @@
>   /* SPDX-License-Identifier: MIT */
>   /*
> - * Copyright © 2019 Intel Corporation
> + * Copyright © 2019-2022 Intel Corporation
>    */
>   
> -#ifndef __INTEL_DE_H__
> -#define __INTEL_DE_H__
> +#ifndef _XE_DE_H_
> +#define _XE_DE_H_
>   
>   #include "i915_drv.h"
>   #include "xe_mmio.h"
> @@ -159,4 +159,4 @@ static inline int intel_de_pcode_request(struct drm_i915_private *i915, u32 mbox
>   				timeout_base_ms);
>   }
>   
> -#endif /* __INTEL_DE_H__ */
> +#endif


More information about the Intel-xe mailing list