[Intel-xe] [PATCH 4/8] drm/xe/irq: Drop unnecessary GEN11_ and GEN12_ register prefixes

Lucas De Marchi lucas.demarchi at intel.com
Fri Mar 31 22:45:03 UTC 2023


On Fri, Mar 31, 2023 at 03:20:12PM -0700, Lucas De Marchi wrote:
>On Thu, Mar 30, 2023 at 11:24:01AM -0700, Matt Roper wrote:
>>Any interrupt registers that were introduced by platforms i915
>>considered to be "gen11" or "gen12" are present on all platforms that
>>the Xe driver supports; drop the unnecessary prefixes.
>>
>>While working in the area, also convert a few open-coded bit
>>manipulations over to REG_BIT and REG_FIELD_GET notation.
>>
>>Signed-off-by: Matt Roper <matthew.d.roper at intel.com>
>>---
>>drivers/gpu/drm/xe/regs/xe_gt_regs.h |  42 +++++------
>>drivers/gpu/drm/xe/regs/xe_regs.h    |  12 +--
>
>I was thinking more on an approach of cleaning up the entire driver:
>get all the defines from regs/* that have the GEN*_ or _GEN* suffix and
>drop the suffix.
>
>I wrote it some time ago, but was having some issues with display/
>failing to compile because of that (some of the ifdef's inside i915 use
>our register defines).
>
>Since this is done for irq, with more contained changes, I won't oppose
>though. It's going in the right direction.
>
>Checked with --color-words and it does what it says

but fails to build:

../drivers/gpu/drm/xe/xe_display.c: In function ‘xe_display_irq_handler’:
../drivers/gpu/drm/xe/xe_display.c:278:26: error: ‘GEN11_DISPLAY_IRQ’ undeclared (first use in this function); did you mean ‘DISPLAY_IRQ’?
   278 |         if (master_ctl & GEN11_DISPLAY_IRQ)
       |                          ^~~~~~~~~~~~~~~~~
       |                          DISPLAY_IRQ


Lucas De Marchi


More information about the Intel-xe mailing list