[PATCH] drm/xe: Use LRC prefix rather than CTX prefix in lrc desc defines

Lucas De Marchi lucas.demarchi at intel.com
Tue Jan 23 19:56:28 UTC 2024


On Tue, Jan 23, 2024 at 10:55:30AM -0800, Matthew Brost wrote:
>The sparc build fails [1] due to CTX_VALID being redefined. Fix this by
>using a better naming convention of LRC_VALID as this define is used in
>setting bits in the lrc descriptor. To be uniform, change other define
>with LRC prefix too.
>
>[1] http://kisskb.ellerman.id.au/kisskb/buildresult/15112267/

how reliable/stable is that link to be in the commit message? maybe
better to point to the email @ lore.kernel.org?

>
>Fixes: 0bc519d20ffa ("drm/xe: Remove GEN[0-9]*_ prefixes")
>Cc: Thomas Hellström <thomas.hellstrom at linux.intel.com>
>Cc: Lucas De Marchi <lucas.demarchi at intel.com>
>Signed-off-by: Matthew Brost <matthew.brost at intel.com>
>---
> drivers/gpu/drm/xe/xe_lrc.c | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
>diff --git a/drivers/gpu/drm/xe/xe_lrc.c b/drivers/gpu/drm/xe/xe_lrc.c
>index f17e9785355e..c005e56847a1 100644
>--- a/drivers/gpu/drm/xe/xe_lrc.c
>+++ b/drivers/gpu/drm/xe/xe_lrc.c
>@@ -23,9 +23,9 @@
> #include "xe_sriov.h"
> #include "xe_vm.h"
>
>-#define CTX_VALID				(1 << 0)
>-#define CTX_PRIVILEGE				(1 << 8)
>-#define CTX_ADDRESSING_MODE_SHIFT		3
>+#define LRC_VALID				(1 << 0)
>+#define LRC_PRIVILEGE				(1 << 8)
>+#define LRC_ADDRESSING_MODE_SHIFT		3
> #define LEGACY_64B_CONTEXT			3

maybe this should also have the prefix (even if it didn't have it
before)?

Lucas De Marchi

>
> #define ENGINE_CLASS_SHIFT			61
>@@ -786,15 +786,15 @@ int xe_lrc_init(struct xe_lrc *lrc, struct xe_hw_engine *hwe,
> 				     (q->usm.acc_notify << ACC_NOTIFY_S) |
> 				     q->usm.acc_trigger);
>
>-	lrc->desc = CTX_VALID;
>-	lrc->desc |= LEGACY_64B_CONTEXT << CTX_ADDRESSING_MODE_SHIFT;
>+	lrc->desc = LRC_VALID;
>+	lrc->desc |= LEGACY_64B_CONTEXT << LRC_ADDRESSING_MODE_SHIFT;
> 	/* TODO: Priority */
>
> 	/* While this appears to have something about privileged batches or
> 	 * some such, it really just means PPGTT mode.
> 	 */
> 	if (vm)
>-		lrc->desc |= CTX_PRIVILEGE;
>+		lrc->desc |= LRC_PRIVILEGE;
>
> 	if (GRAPHICS_VERx100(xe) < 1250) {
> 		lrc->desc |= (u64)hwe->instance << ENGINE_INSTANCE_SHIFT;
>-- 
>2.34.1
>


More information about the Intel-xe mailing list