[PATCH 2/2] drm/xe: Normalize bo flags macros

Matthew Auld matthew.auld at intel.com
Thu Mar 14 17:19:11 UTC 2024


On 14/03/2024 05:26, Lucas De Marchi wrote:
> The flags stored in the BO grew over time without following
> much a naming pattern. First of all, get rid of the _BIT suffix that was
> banned from everywhere else due to the guideline in
> drivers/gpu/drm/i915/i915_reg.h that xe kind of follows:
> 
> 	Define bits using ``REG_BIT(N)``. Do **not** add ``_BIT`` suffix to the name.
> 
> Here the flags aren't for a register, but it's good practice to keep it
> consistent.
> 
> Second divergence on names is the use or not of "CREATE". This is
> because most of the flags are passed to xe_bo_create*() family of
> functions, changing its behavior. However, since the flags are also
> stored in the bo itself and checked elsewhere in the code, it seems
> better to just omit the CREATE part.
> 
> With those 2 guidelines, all the flags are given the form
> XE_BO_FLAG_<FLAG_NAME> with the following commands:
> 
> 	git grep -le "XE_BO_" -- drivers/gpu/drm/xe | xargs sed -i \
> 		-e "s/XE_BO_\([_A-Z0-9]*\)_BIT/XE_BO_\1/g" \
> 		-e 's/XE_BO_CREATE_/XE_BO_FLAG_/g'
> 	git grep -le "XE_BO_" -- drivers/gpu/drm/xe | xargs sed -i -r \
> 		-e 's/XE_BO_(DEFER_BACKING|SCANOUT|FIXED_PLACEMENT|PAGETABLE|NEEDS_CPU_ACCESS|NEEDS_UC|INTERNAL_TEST|INTERNAL_64k)/XE_BO_FLAG_\1/g'
> 
> And then the defines in drivers/gpu/drm/xe/xe_bo.h are adjusted to
> follow the coding style.
> 
> Signed-off-by: Lucas De Marchi <lucas.demarchi at intel.com>

Looks like a nice cleanup to me,
Reviewed-by: Matthew Auld <matthew.auld at intel.com>


More information about the Intel-xe mailing list