[PATCH 0/6] drm/i915/dp_mst: Clean up active stream count tracking

Imre Deak imre.deak at intel.com
Fri Apr 4 15:03:04 UTC 2025


As requested by Jani, this patchset cleans up the MST active stream
count tracking, using the logical name for the counter (stream vs.
link) and adding helpers to simplify the functions where the counter is
queried.

Cc: Jani Nikula <jani.nikula at intel.com>

Imre Deak (6):
  drm/i915/dp: Rename intel_dp::link_trained to link.active
  drm/i915/dp_mst: Add intel_dp_mst_{inc,dec}_active_streams()
  drm/i915/dp_mst: Remove stream count assert from
    intel_dp_check_mst_status()
  drm/i915/dp_mst: Rename intel_dp_mst_encoder_active_links() to
    intel_dp_mst_active_streams()
  drm/i915/dp_mst: Use intel_dp_mst_active_streams() instead of
    open-coding it
  drm/i915/dp_mst: Rename intel_dp::mst.active_links to
    mst.active_streams

 drivers/gpu/drm/i915/display/g4x_dp.c         |  2 +-
 drivers/gpu/drm/i915/display/intel_ddi.c      | 10 +--
 .../drm/i915/display/intel_display_types.h    |  4 +-
 drivers/gpu/drm/i915/display/intel_dp.c       | 10 ++-
 .../drm/i915/display/intel_dp_link_training.c |  8 +--
 drivers/gpu/drm/i915/display/intel_dp_mst.c   | 66 +++++++++++--------
 drivers/gpu/drm/i915/display/intel_dp_mst.h   |  2 +-
 drivers/gpu/drm/i915/display/intel_hdcp.c     |  3 +-
 drivers/gpu/drm/i915/display/intel_tc.c       | 20 +++---
 9 files changed, 67 insertions(+), 58 deletions(-)

-- 
2.44.2



More information about the Intel-xe mailing list