✗ CI.checkpatch: warning for DPLL framework redesign (rev3)

Patchwork patchwork at emeril.freedesktop.org
Mon Apr 7 13:57:11 UTC 2025


== Series Details ==

Series: DPLL framework redesign (rev3)
URL   : https://patchwork.freedesktop.org/series/145380/
State : warning

== Summary ==

+ KERNEL=/kernel
+ git clone https://gitlab.freedesktop.org/drm/maintainer-tools mt
Cloning into 'mt'...
warning: redirecting to https://gitlab.freedesktop.org/drm/maintainer-tools.git/
+ git -C mt rev-list -n1 origin/master
99e5a866b5e13f134e606a3e29d9508d97826fb3
+ cd /kernel
+ git config --global --add safe.directory /kernel
+ git log -n1
commit 970f8ce5a8c26ef0c3ef7e04268f6b5ec9b3c199
Author: Suraj Kandpal <suraj.kandpal at intel.com>
Date:   Mon Apr 7 13:46:54 2025 +0530

    drm/i915/dpll: Rename intel_update_active_dpll
    
    Rename intel_update_active_dpll to intel_dpll_update_active in an
    effort to have function names which are exported to start with
    filenames they are exported from.
    
    Signed-off-by: Suraj Kandpal <suraj.kandpal at intel.com>
+ /mt/dim checkpatch 100ba24787e877cd422caa7d08cb046ef4bb769c drm-intel
d1ee3db0bb51 drm/i915/dpll: Rename intel_dpll
7a7318f1b468 drm/i915/dpll: Rename intel_dpll_funcs
54266a493777 drm/i915/dpll: Rename intel_shared_dpll_state
b86e73d1e626 drm/i915/dpll: Rename macro for_each_shared_dpll
-:102: CHECK:MACRO_ARG_REUSE: Macro argument reuse '__display' - possible side-effects?
#102: FILE: drivers/gpu/drm/i915/display/intel_dpll_mgr.h:33:
+#define for_each_dpll(__display, __pll, __i) \
 	for ((__i) = 0; (__i) < (__display)->dpll.num_shared_dpll && \
 		     ((__pll) = &(__display)->dpll.shared_dplls[(__i)]) ; (__i)++)

-:102: CHECK:MACRO_ARG_REUSE: Macro argument reuse '__i' - possible side-effects?
#102: FILE: drivers/gpu/drm/i915/display/intel_dpll_mgr.h:33:
+#define for_each_dpll(__display, __pll, __i) \
 	for ((__i) = 0; (__i) < (__display)->dpll.num_shared_dpll && \
 		     ((__pll) = &(__display)->dpll.shared_dplls[(__i)]) ; (__i)++)

total: 0 errors, 0 warnings, 2 checks, 81 lines checked
54dc362f06ab drm/i915/dpll: Rename intel_shared_dpll_funcs
ff993dc52fd4 drm/i915/dpll: Rename intel_shared_dpll
b95ded8a94ad drm/i915/dpll: Move away from using shared dpll
a00d749c033e drm/i915/dpll: Rename crtc_get_shared_dpll
3e81a3507b30 drm/i915/dpll: Change argument for enable hook in intel_dpll_funcs
4a79dca43d40 drm/i915/drm: Rename disable hook in intel_dpll_global_func
210c74752d66 drm/i915/dpll: Introduce new hook in intel_dpll_funcs
dcfd29712151 drm/i915/dpll: Add intel_encoder argument to get_hw_state hook
30e1af7f53fb drm/i915/dpll: Change arguments for get_freq hook
b10c0d6ca1eb drm/i915/dpll: Rename intel_[enable/disable]_dpll
558951d956b8 drm/i915/dpll: Rename intel_unreference_dpll__crtc
2289cb813ce9 drm/i915/dpll: Rename intel_<release/reserve>_dpll
2955799038a9 drm/i915/dpll: Rename intel_compute_dpll
970f8ce5a8c2 drm/i915/dpll: Rename intel_update_active_dpll




More information about the Intel-xe mailing list