[PATCH v5 0/2] drm/xe: Add and refactor workarounds
Aradhya Bhatia
aradhya.bhatia at intel.com
Thu Feb 20 09:46:43 UTC 2025
Hello,
This patch series adds the workarounds, Wa_16021333562, and Wa_14016712196.
It further refactors Wa_18013179988, Wa_14015568240, Wa_1508761755, and
Wa_1509372804, to use the newer macro, XE_WA(), for OOB workarounds,
instead of selection based on platform labels.
Thanks,
Aradhya
---
Change Log:
V5:
- Rename LRC_PPHWSP_SCRATCH_ADDR to LRC_PPHWSP_FLUSH_INVAL_SCRATCH_ADDR
in the WA implementation, as the name has gotten updated in commit
f0c06677d110 ("drm/xe/pxp: Add VCS inline termination support"), in
patch 1/2, as reported by Lucas De Marchi.
- Move the Wa_14016712196 diff chunk above all the flags and calculations
for better clarity in patch-1/2, as recommended by Lucas De Marchi.
- Add R-b tags of Tejas Upadhyay in patch-1, and Lucas De Marchi in
patch-2.
V4:
- Combine Wa_16021333562 condition check with another workaround in
patch-1, as suggested by Tejas Upadhyay.
- Fix the offset value for the pipe control emit for Wa_14016712196 in
patch-1, as suggested by Tejas Upadhyay.
- Add Tejas Upadhyay's R-b tag for patch-2.
V3:
- Fix the applicable Gfx platform ranges for WAs, in patches 1, and 2.
- Add more WAs for refactoring in patch-2, and reword it accordingly.
V2:
- Add new patch (patch-2/2) which involves refactoring the WA
implementation as suggested by Lucas De Marchi.
- Expand the ranges of Wa_16021333562 and Wa_14016712196 as per WA
database, in patch-1/2, and in that process add the WAs properly
instead of porting them for a select few platforms.
- Reword the commit subject and commit text in patch-1 accordingly.
Previous Revisions:
V1: https://lore.kernel.org/all/20250115080048.2282183-1-aradhya.bhatia@intel.com/
V2: https://lore.kernel.org/all/20250116091004.3060996-1-aradhya.bhatia@intel.com/
V3: https://lore.kernel.org/all/20250120060916.778406-1-aradhya.bhatia@intel.com/
V4: https://lore.kernel.org/all/20250130055939.282988-1-aradhya.bhatia@intel.com/
Aradhya Bhatia (2):
drm/xe: Add Wa_16021333562 and Wa_14016712196
drm/xe/oa: Refactor WAs to use XE_WA() macro
drivers/gpu/drm/xe/xe_guc_ads.c | 2 +-
drivers/gpu/drm/xe/xe_oa.c | 30 +++++++++---------------------
drivers/gpu/drm/xe/xe_ring_ops.c | 4 ++++
drivers/gpu/drm/xe/xe_wa_oob.rules | 9 +++++++++
4 files changed, 23 insertions(+), 22 deletions(-)
base-commit: a1e5b6d83e03d60d15ba393cbbd7d5c13e5cf0b3
--
2.34.1
More information about the Intel-xe
mailing list