[PATCH 0/4] drm/xe: Unify IP descriptors

Gustavo Sousa gustavo.sousa at intel.com
Thu Feb 20 17:25:07 UTC 2025


The Xe driver has support, official or not, for both pre-GMDID and
GMDID-based IPs. For each type, we have been using a different approach
for describing instances:

- For pre-GMDID ones, we fully describe the IP via struct
  xe_{graphics,media}_desc.

- For GMDID-based ones, we have IP info separated in different data
  structures: instances of xe_{graphics,media}_desc are used to describe
  IP names and features; while instances of gmdid_map effectively fully
  describe the IPs, by mapping IP versions to descriptors.

In this series I propose that we use a unified approach to describe IPs:

- struct xe_{graphics,media}_desc purpose becomes to only describe
  features of the IP and can be reused across releases if possible (the
  latter is already done with the current approach);

- struct gmdid_map is turned into struct xe_ip, to fully describe an IP;

- the field "name" is moved from xe_{graphics,media}_desc to xe_ip,
  making the former specifically about the features while xe_ip
  incorporates features and release info.

Gustavo Sousa (4):
  drm/xe: Set IP names in functions handling IP version
  drm/xe: Disambiguate GMDID-based IP names
  drm/xe: Rename gmdid_map to xe_ip
  drm/xe: Convert pre-GMDID IPs to struct xe_ip

 drivers/gpu/drm/xe/tests/xe_pci.c |  24 +++---
 drivers/gpu/drm/xe/xe_pci.c       | 118 +++++++++++++++---------------
 drivers/gpu/drm/xe/xe_pci_types.h |  15 +---
 3 files changed, 77 insertions(+), 80 deletions(-)

-- 
2.48.1



More information about the Intel-xe mailing list