✗ CI.checkpatch: warning for drm/xe/xe_vm: Implement xe_vm_get_property_ioctl (rev14)
Patchwork
patchwork at emeril.freedesktop.org
Tue Mar 25 23:24:14 UTC 2025
== Series Details ==
Series: drm/xe/xe_vm: Implement xe_vm_get_property_ioctl (rev14)
URL : https://patchwork.freedesktop.org/series/145529/
State : warning
== Summary ==
+ KERNEL=/kernel
+ git clone https://gitlab.freedesktop.org/drm/maintainer-tools mt
Cloning into 'mt'...
warning: redirecting to https://gitlab.freedesktop.org/drm/maintainer-tools.git/
+ git -C mt rev-list -n1 origin/master
99e5a866b5e13f134e606a3e29d9508d97826fb3
+ cd /kernel
+ git config --global --add safe.directory /kernel
+ git log -n1
commit d62b2f12b7665515ad2196e9818ac6ae18a4670f
Author: Jonathan Cavitt <jonathan.cavitt at intel.com>
Date: Tue Mar 25 22:27:23 2025 +0000
drm/xe/xe_vm: Implement xe_vm_get_property_ioctl
Add support for userspace to request a list of observed faults
from a specified VM.
v2:
- Only allow querying of failed pagefaults (Matt Brost)
v3:
- Remove unnecessary size parameter from helper function, as it
is a property of the arguments. (jcavitt)
- Remove unnecessary copy_from_user (Jainxun)
- Set address_precision to 1 (Jainxun)
- Report max size instead of dynamic size for memory allocation
purposes. Total memory usage is reported separately.
v4:
- Return int from xe_vm_get_property_size (Shuicheng)
- Fix memory leak (Shuicheng)
- Remove unnecessary size variable (jcavitt)
v5:
- Rename ioctl to xe_vm_get_faults_ioctl (jcavitt)
- Update fill_property_pfs to eliminate need for kzalloc (Jianxun)
v6:
- Repair and move fill_faults break condition (Dan Carpenter)
- Free vm after use (jcavitt)
- Combine assertions (jcavitt)
- Expand size check in xe_vm_get_faults_ioctl (jcavitt)
- Remove return mask from fill_faults, as return is already -EFAULT or 0
(jcavitt)
v7:
- Revert back to using xe_vm_get_property_ioctl
- Apply better copy_to_user logic (jcavitt)
v8:
- Fix and clean up error value handling in ioctl (jcavitt)
- Reapply return mask for fill_faults (jcavitt)
v9:
- Future-proof size logic for zero-size properties (jcavitt)
- Add access and fault types (Jianxun)
- Remove address type (Jianxun)
v10:
- Remove unnecessary switch case logic (Raag)
- Compress size get, size validation, and property fill functions into a
single helper function (jcavitt)
- Assert valid size (jcavitt)
v11:
- Remove unnecessary else condition
- Correct backwards helper function size logic (jcavitt)
Signed-off-by: Jonathan Cavitt <jonathan.cavitt at intel.com>
Suggested-by: Matthew Brost <matthew.brost at intel.com>
Cc: Jainxun Zhang <jianxun.zhang at intel.com>
Cc: Shuicheng Lin <shuicheng.lin at intel.com>
Cc: Raag Jadav <raag.jadav at intel.com>
+ /mt/dim checkpatch afc2e1fea0a406eedbaf632e96cdb6832a45ebb7 drm-intel
edc0cde82d53 drm/xe/xe_hw_engine: Map xe and user engine class in header
9422fff145e2 drm/xe/xe_gt_pagefault: Disallow writes to read-only VMAs
c21753312f8d drm/xe/xe_gt_pagefault: Move pagefault struct to header
-:35: WARNING:FILE_PATH_CHANGES: added, moved or deleted file(s), does MAINTAINERS need updating?
#35:
new file mode 100644
total: 0 errors, 1 warnings, 0 checks, 220 lines checked
f80f04e8ab72 drm/xe/uapi: Define drm_xe_vm_get_property
-:42: WARNING:LONG_LINE: line length of 122 exceeds 100 columns
#42: FILE: include/uapi/drm/xe_drm.h:122:
+#define DRM_IOCTL_XE_VM_GET_PROPERTY DRM_IOWR(DRM_COMMAND_BASE + DRM_XE_VM_GET_PROPERTY, struct drm_xe_vm_get_property)
total: 0 errors, 1 warnings, 0 checks, 103 lines checked
1bc5b38d8a0f drm/xe/xe_vm: Add per VM fault info
-:141: WARNING:OOM_MESSAGE: Possible unnecessary 'out of memory' message
#141: FILE: drivers/gpu/drm/xe/xe_vm.c:803:
+ if (!e) {
+ drm_warn(&vm->xe->drm,
total: 0 errors, 1 warnings, 0 checks, 207 lines checked
d62b2f12b766 drm/xe/xe_vm: Implement xe_vm_get_property_ioctl
More information about the Intel-xe
mailing list