guillem at hadrons.org
Thu Dec 27 02:09:21 PST 2012
On Wed, 2012-12-26 at 15:12:03 -0600, Peter da Silva wrote:
> Looking at the FreeBSD man pages, the function that reverses the
> effect of "humanize_number" is "expand_number" rather than
> "dehumanize_number". The source code to bsd/libutil.h in your source
> tree also lists "expand_number" but not "dehumanize_number". Code for
> both variants are included, with no attempt at unifying them.
> Is this somewhat confused situation intentional?
dehumanize_number(3) comes from NetBSD and it's declared in <stdlib.h>.
It's provided because projects with NetBSD origins might use it, so its
inclusion is intentional, the code duplication is not, but I've fixed
this now locally by switching dehumanize_number(3) to be a strong alias
to expand_number(3), which seemed to be more complete.
This will be included in my next push targetting 0.5.x.
More information about the libbsd