Bjørn Mork bjorn at mork.no
Wed Mar 2 18:31:09 UTC 2016

Bjørn Mork <bjorn at mork.no> writes:

> Bjørn Mork <bjorn at mork.no> writes:
>> And wow, there it worked!
> Cancel that.  Sorry.  I cannot repeat it.   It just worked once to annoy
> me.  Yuck again.

OK, I think I got it.  The device fails if you try to configure it while
it is still booting, but the USB descriptors are visible before this is
complete. So your normal Linux use case:

 plug modem => driver autoloading and probing

consistently fails.  But if you unload and reload the driver, like you
do when you test out driver modifications, then everything just works.
Thanks a lot Huawei.  That's nice of you, creating a modem that works
for me but not for the rest of the world ;)

And FWIW, the NDP-to-end quirk is still required.  Looks like we will
need another one as well, delaying setup somewhat for these modems.
Don't know how else to support this.  There doesn't seem to be anything
we can use to detect when it is ready and when it is not.  The USB
control requests succeed either way, and it always reports 16-bit mode
when you query it.


More information about the libmbim-devel mailing list