Thinkpad X1 w/ EM7455 stuck in "sim-missing"

Murph Murph at
Thu Oct 12 14:33:11 UTC 2017


I've got a recently purchased Thinkpad Carbon X1 (5th gen) wich
comes with an integrated Sierra Wireless EM7455 modem.

It seems stuck in a "sim-missing" state. I'm not sure if this is
the best mailing list, so please feel free to redirect me.

I've tried two brand-new Project Fi SIM cards, so I don't think
it's the SIM.

I've tried rebooting a few times, and running commands right after boot
or waiting a few minutes, it didn't seem to help.

Here's my system information:
# lsusb
Bus 001 Device 002: ID 1199:9079 Sierra Wireless, Inc.

# dmesg
[    1.862947] usb 1-6: New USB device strings: Mfr=1, Product=2,
[    1.862948] usb 1-6: Product: Sierra Wireless EM7455 Qualcomm Snapdragon
[    1.862949] usb 1-6: Manufacturer: Sierra Wireless, Incorporated
[    1.862949] usb 1-6: SerialNumber: LF73827012021020

# uname-r

# emerge -pv libmbim libqmi modemmanager
Packages installed:
[ebuild   R    ] net-libs/libmbim-1.14.0::gentoo  USE="udev -static-libs" 0
[ebuild   R    ] net-libs/libqmi-1.18.0:0/5.1::gentoo  USE="mbim -doc
-static-libs" 0 KiB
[ebuild   R    ] net-misc/modemmanager-1.6.4:0/1::gentoo
USE="introspection mbim (policykit) qmi -systemd -vala" 0 KiB

# mmcli -L
Found 1 modems:
        /org/freedesktop/ModemManager1/Modem/0 [Sierra] MBIM [1199:9079]

# mmcli -m 0
/org/freedesktop/ModemManager1/Modem/0 (device id
  Hardware |   manufacturer: 'Sierra'
           |          model: 'MBIM [1199:9079]'
           |       revision: 'SWI9X30C_02.20.03.00'
           |      supported: 'gsm-umts, lte'
           |        current: 'gsm-umts, lte'
           |   equipment id: '014582008979065'
  System   |         device: '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-6'
           |        drivers: 'cdc_mbim'
           |         plugin: 'Sierra'
           |   primary port: 'cdc-wdm0'
           |          ports: 'wwp0s20f0u6i12 (net), cdc-wdm0 (mbim)'
  Numbers  |           own : 'unknown'
  Status   |           lock: 'unknown'
           | unlock retries: 'unknown'
           |          state: 'failed'
           |  failed reason: 'sim-missing'
           |    power state: 'low'
           |    access tech: 'unknown'
           | signal quality: '0' (cached)
Modes    |      supported: 'allowed: 3g, 4g; preferred: none'
           |        current: 'allowed: any; preferred: none'
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  IP       |      supported: 'ipv4, ipv6, ipv4v6'
  SIM      |           path: 'none'

  Bearers  |          paths: 'none'

# mbimcli -p -d /dev/cdc-wdm0 --query-subscriber-ready-status
[/dev/cdc-wdm0] Subscriber ready status retrieved:
              Ready state: 'sim-not-inserted'
            Subscriber ID: 'unknown'
                SIM ICCID: 'unknown'
               Ready info: 'unknown'
        Telephone numbers: (0) 'unknown'

I get a lot of timeouts with qmicli:

# qmicli -d /dev/cdc-wdm0 --device-open-mbim --uim-get-card-status
error: couldn't open the QmiDevice: Transaction timed out
# qmicli -d /dev/cdc-wdm0 --device-open-mbim --uim-get-card-status
error: couldn't open the QmiDevice: Transaction timed out
# qmicli -d /dev/cdc-wdm0 --device-open-mbim --uim-get-card-status
error: couldn't create client for the 'uim' service: CID allocation failed
in the CTL client: MBIM error: Transaction timed out
# qmicli -d /dev/cdc-wdm0 --device-open-mbim --uim-get-card-status

Any suggestions? I'm a developer myself, so I'm comfortable with
building from git or kernel changes or w/e to debug.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the libmbim-devel mailing list