[Liboil] liboil strange build problem

Johnny Eriksson johnny.eriksson at clearit.se
Thu Dec 8 04:21:29 PST 2005

Problem solved.

At closer look at what compiler i used it apeared that i was not
using a newer compiler or older. (problem path).

So when i went from gcc 3.2.3 to 3.3.3 it build without any
problems. Puh! :)

I spent like 2 days on this matter trying different configuration and
setups :D

Thanks anyway.
Keep up the good work guys!

Best regards,

Citerar Johnny Eriksson <johnny.eriksson at clearit.se>:

> Hi
> I have succesfully build liboil on my machines at home with various
> specs. (PIII, P4, M).
> At work i'm wrestling with a problem to build it on a P4 machine with
> hyperthreading enabled. It does not matter what version of GCC i'm
> using (3.2 -> 3.4) it always stops with this. I even tried different
> kernels and headers but no positive result. I also tried different
> version of liboil 0.3.3 -> 0.3.6 i even checked out the latest
> and greatest from cvs.
> fbmmx.c: In function `fbCompositeSolid_nx8888mmx':
> fbmmx.c:902: can't convert between vector values of different size
> fbmmx.c:926: can't convert between vector values of different size
> I really need some help on this.
> Many thanks in advance.
> Best regards,
> Johnny
> _______________________________________________
> Liboil mailing list
> Liboil at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/liboil

More information about the Liboil mailing list