Reg: IPv6 on MC7354

Balaji Sivakumar shivbalaji1985 at
Sat Feb 4 18:41:48 UTC 2017


I am trying to get IPv6 address on MC7354 via following procedures


2) qmicli -d /dev/cdc-wdm1 --wds-start-network=internet

3) dhclient -6 wwan1 (I tried -N -T -P -S options and still failed.)

I have also tried creating dual stack connection using different CID's but
still am getting IPv4 address.

qmicli -p -d /dev/cdc-wdm1 --wds-noop --client-no-release-cid


qmicli -p -d /dev/cdc-wdm1 --wds-noop --client-no-release-cid


qmicli -v -p -d /dev/cdc-wdm1 --wds-start-network=apn=VZWINTERNET
--client-cid=x --client-no-release-cid

qmicli -v -p -d /dev/cdc-wdm1 --wds-start-network=apn=VZWINTERNET
--client-cid=y --client-no-release-cid

When I use to get the current settings am getting only IPv4. Am very sure
the profile am using to connect supports both IPv4v6

# qmicli -V

qmicli 1.16.0

I have confirmed the IPv6 address is already in MC7354, but the device
cannot get IPv6 address via dhclient. Also tried udhcpc too but still
getting IPv4 address.

As many mentioned in most of the queries, I have tried all the options but
still no ipv6 only am getting ipv4.

Can you provide your suggestions/procedures?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the libqmi-devel mailing list