Neoway n720 (mPCIe version) - uqmi hangs

Aleksander Morgado aleksander at aleksander.es
Tue Nov 21 07:54:51 UTC 2017


Hey,

>
> As per your suggestion, I have manged to install modemmanager on
> openwrt(using the instructions here
> https://bitbucket.org/aleksander0m/modemmanager-openwrt). But I'm unable to
> get IP address on my wwan0 interface(I was able to get it using the default
> proto qmi ). Am I missing something here?
>
> Here's my configurations that works and through which I get an IP address on
> the wwan0 interface -
>
> config interface 'wanSIM0'
>         option proto 'qmi'
>         option metric '10'
>         option apn 'internet'
>         option modes 'all'
>         option ifname 'wwan0'
>         option device '/dev/cdc-wdm0'
>
>
>
> But when I change the configuration, as per the modemmanager README, it does
> not get an IP address on the wwan0 interface -
>
> config interface 'wanSIM0'
>         option proto 'modemmanager'
>         option metric '10'
>         option apn 'internet'
>         option modes 'all'
>         option ifname 'wwan0'
>         option device '/dev/cdc-wdm0'
>
> I'm able to get the ipaddress using qmicli using proto 'modemmanager' though
>
> saurabh at iotgateway:~# qmicli -d /dev/cdc-wdm0 --wds-get-current-settings
> [/dev/cdc-wdm0] Current settings retrieved:
>            IP Family: IPv4
>         IPv4 address: 10.192.23.88
>     IPv4 subnet mask: 255.255.255.240
> IPv4 gateway address: 10.192.23.89
>     IPv4 primary DNS: 220.226.100.40
>   IPv4 secondary DNS: 220.226.6.104
>                  MTU: 1500
>              Domains: none
>
> Kindly let me know. I'm using openWRT chaos calmer 15.05(kernel 4.4.7)
>

For the "modemmanager" proto, you shouldn't provide a "ifname" with
the wwan network interface name and a "device" with the cdc-wdm
interface name. Instead, the README tells you to use a configuration
like this one:

    config interface 'wanSIM0'
        option device   '/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3'
        option proto    'modemmanager'
        option apn      'internet'

i.e. only "device" is needed, pointing to the full sysfs path of the
modem device. This sysfs path is ensured to be the same across reboots
as long as the hw layout isn't changed. You can get a hint of what
your sysfs path is by executing:

$ realpath /sys/class/net/wwan0
/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.4/net/wwan0

Given the path above, the full sysfs path of your modem would be
/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3


-- 
Aleksander
https://aleksander.es


More information about the libqmi-devel mailing list