qmi-network fails to start

BenoƮt benoit at neviani.fr
Tue Oct 10 21:36:15 UTC 2017

Hi Aleksander,

I tried but I got an error.

mbim-network /dev/cdc-wdm0 start 
Network started successfully

mbimcli -d /dev/cdc-wdm0 --query-ip-configuration  
error: couldn't get IP configuration response message: ContextNotActivated

Just after launching this command a status reports an error:
error: operation failed: MBIM protocol error: NotOpened
error: couldn't get connection status

(I also tested with your suggested session ID with the same issue)

I remember having some similar issues in the past with another wwan card
and I switched the card thanks to an UDEV rule, using the same here is not
putting the card into qmi mode.

SUBSYSTEM=="usb",ATTR{idVendor}=="1199",ATTR{idProduct}=="9079",ATTR{bConfigurationValue}=="2" ATTR{bConfigurationValue}="1"

I also tried to blacklist cdc_mbim to test but I don't see /dev/cdc-wdm0
anymore (I think it is expected) I also tried to blacklist qmi_wwan but
no success.

I also check that FCC is successfully passed, anyway without I am unable
to put the card in software radio state 'on', after applying the FCC I

mbimcli -d /dev/cdc-wdm0 --query-radio-state
[/dev/cdc-wdm0] Radio state retrieved:
	     Hardware Radio State: 'on'
	     Software Radio State: 'on'

I feel I am about to make it work but I am unable to find the reason
after testing a lot of tries..

Many thanks for your help :)

On Sun, Oct 08, 2017 at 01:35:41PM +0200, Aleksander Morgado wrote:
>> Thanks I tried it already but got an error.
>> Just to be sure is there a way to double check the session id?
>You get the session ID when running --connect=[...]; although I
>believe you can ignore the parameter and just run it without
>arguments, e.g.:
>$ mbimcli -d /dev/cdc-wdm0 --query-ip-configuration


More information about the libqmi-devel mailing list