MC7455 with qmicli: Transaction timed out

Tomcsányi, Domonkos domi at
Fri Mar 1 09:59:29 UTC 2019

Hello Sampo,

Could you try with specifying the -p option (for using qmi proxy)?

It might help with this issue.


2019. márc. 1. dátummal, 10:33 időpontban Sampo Pitkanen <Sampo.Pitkanen at> írta:

> Hello,
> I am using a custom Linux board with kernel version 4.9 and qmicli version 1.22.0. I have used a MC7304 for two years with no problems.
> I have now tried updating to both a MC7455 and MC7430. Initially neither worked, every qmicli command I made resulted in a “transaction timed out” message.
> I then updated both qmi_wwan.c and qcserial.c to the latest version (from kernel 5.0-rc8). MC7430 started working, but MC7455 still does not work. For example trying to change the data format looks like this:
> qmicli -d /dev/cdc-wdm0 --wda-set-data-format=802-3
> error: couldn't create client for the 'wda' service: CID allocation failed in the CTL client: Transaction timed out
> I can get the modem to respond to QMI messages using the GobiNet and GobiSerial drivers provided by sierra Wireless, but I really don’t want to develop my own cli using those drivers, I’d much rather continue using qmicli.
> Anyone have any ideas?
> Sampo
> _______________________________________________
> libqmi-devel mailing list
> libqmi-devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the libqmi-devel mailing list