[Libreoffice-bugs] [Bug 36375] New: LibO 3.4 beta1 - swriter.exe fails to open

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Apr 19 06:40:56 CEST 2011


https://bugs.freedesktop.org/show_bug.cgi?id=36375

           Summary: LibO 3.4 beta1 - swriter.exe fails to open
           Product: LibreOffice
           Version: LibO 3.4 Beta1
          Platform: x86 (IA32)
        OS/Version: Windows (All)
            Status: NEW
          Severity: blocker
          Priority: medium
         Component: Writer
        AssignedTo: libreoffice-bugs at lists.freedesktop.org
        ReportedBy: zcreveling at gmail.com


Created an attachment (id=45794)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=45794)
Screenshot of error message

I try to open writer and I get this error message:
General Error.
General input/output error.

It doesn't matter if I try to start writer from the startcenter (as shown in
the screenshot) or I manually try to open swriter.exe, I get the same error
message.  This bug was originally Bug 36271 but that has morphed into the bug
which deals with opening files.  Either way, they are related as the same error
message occurs.

I tried the instructions as proposed by Allen in Bug 36271 which read:
(In reply to comment #14)
> Could the users who are seeing this problem (or a related problem) try the
> following:
> 
> 1. Run LibreOffice to confirm the problem.
> 2. Close LibreOffice.
> 3. If the LibreOffice Quickstarter is running, right-click on the LibreOffice
> Quickstarter icon in the system tray and select "Exit Quickstarter".
> 4. Run taskmgr (Start -> Run -> type "taskmgr" and hit Enter).
> 5. Verify that there are no processes running with names that start with
> "soffice" (such as "soffice.exe" or "soffice.bin").
> 6. Navigate to your user setting directory (open the Windows File Explorer,
> type %APPDATA$ in the location bar and hit Enter).
> 7. You should see a subfolder called "LibreOffice".  Rename this subfolder to
> something else, like "LibreOffice-save".
> 8. Run LibreOffice and check to see if the problem is still occurs.
> 
> If the problem is still there, do the following if you are running Vista or
> Windows 7; otherwise, skip to Step 14 below:
> 
> 9. Repeat Steps 2-6 above, and then:
> 10. In your user settings directory, delete the subfolder named LibreOffice.
> 11. Navigate to your VirtualStore folder, which is at C:\Users\<your
> username>\AppData\Local\VirtualStore.
> 12. Look in all subfolders for any subfolders named "LibreOffice" or
> "LibreOffice 3", and if you find one, delete it.
> 13. Run LibreOffice and check to see if the problem is still occurs.
> 
> If the problem is still there:
> 
> 14. Repeat Steps 2-6 above, and then:
> 15. In your user settings directory, delete the subfolder named LibreOffice.
> 16. Uninstall LibreOffice.
> 17. Delete the folder named "LibreOffice 3" in the Windows programs directory
> (either "C:\Program Files\LibreOffice 3" or "C:\Program Files (x86)\LibreOffice
> 3", depending on whether you are running a 32 bit or 64 bit version of
> Windows).
> 18. Reboot your computer.
> 19. Reinstall LibreOffice.
> 20. Run LibreOffice and check to see if the problem is still occurs.
> 
> If any of the above helps, please post which step solved the problem.

Step 7 solves the problem and allows writer to run.  However, upon exiting LO
(doesn't matter what component is running) soffice.exe crashes every time.

Hope some of this helps!

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the Libreoffice-bugs mailing list