[Libreoffice-bugs] [Bug 36678] Missing user-defined dictionaries with a specified language attribute via "Spelling and Grammar" <F7>

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Apr 29 22:52:18 CEST 2011


https://bugs.freedesktop.org/show_bug.cgi?id=36678

manj_k <courrier.oou.fr.mjk at googlemail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|spellchecking: only         |Missing user-defined
                   |standard.dic appears        |dictionaries with a
                   |                            |specified language
                   |                            |attribute via "Spelling and
                   |                            |Grammar" <F7>
          Component|Writer                      |Linguistic component

--- Comment #1 from manj_k <courrier.oou.fr.mjk at googlemail.com> 2011-04-29 13:52:18 PDT ---
Open Writer

(1)
Tools > Options > Language Settings > Writing Aids > 
User-defined dictionaries > New...

Create custom dictionaries as follows
1. add_de [Language: German (Germany)]
2. add_en [Language: English (USA)]
3. add_fr [Language: French (France)]
4. add_all [Language: All]

(2)
Test "AutoSpellcheck"

1. Type some misspelled text [language attribute German (Germany)]
2. Right click on misspelled word
3. Context menu "Add" shows the custom dictionaries:
- standard.dic
- add_de.dic
- add_all.dic
[as expected]

(3)
Test Spelling and Grammar <F7>
1. Same text as before (2)
2. Open "Spelling and Grammar" with <F7>
3. Click on "Add" for a misspelled word; shown custom dictionaries:
- standard.dic
- add_all.dic 

Bug: missing add_de.dic

(4)
Repeat the test cases (2) and (3)
with the language attributes French (France) and English (USA).

The same bug for "Spelling and Grammar" <F7>:
missing add_fr.dic or add_en.dic.

You cannot add a word to user-defined dictionaries with a specified language
attribute via "Spelling and Grammar" <F7>

-- 
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the Libreoffice-bugs mailing list