[Libreoffice-commits] core.git: include/tools

Noel Grandin noel.grandin at collabora.co.uk
Fri Feb 16 06:28:24 UTC 2018


 include/tools/gen.hxx |   12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

New commits:
commit 28753a11d4d5198d473660f386176cec5a1b4533
Author: Noel Grandin <noel.grandin at collabora.co.uk>
Date:   Thu Feb 15 16:15:26 2018 +0200

    rename MoveFoo to AdjustFoo in Point/Rect/Size
    
    <sberg> noel_grandin, "MoveLeft" is a somewhat misleading function name
    in dd4fc3b1e3f8a7c69a44c26715b2e3cdb22aede9
    <noel_grandin> sberg, better ideas?
    <sberg> AdjustLeft etc., like the AdjustWidth/Height?
    <noel_grandin> sberg, sure, np
    
    Change-Id: I89e281b5c7421825098e5ad5a3550c774300938c
    Reviewed-on: https://gerrit.libreoffice.org/49818
    Reviewed-by: Noel Grandin <noel.grandin at collabora.co.uk>
    Tested-by: Noel Grandin <noel.grandin at collabora.co.uk>

diff --git a/include/tools/gen.hxx b/include/tools/gen.hxx
index 0e5289b0765c..38ca77af9046 100644
--- a/include/tools/gen.hxx
+++ b/include/tools/gen.hxx
@@ -82,8 +82,8 @@ public:
     long&               Y() { return nB; }
 
     void                Move( long nHorzMove, long nVertMove );
-    void                MoveX( long nHorzMove ) { nA += nHorzMove; }
-    void                MoveY( long nVertMove ) { nB += nVertMove; }
+    void                AdjustX( long nHorzMove ) { nA += nHorzMove; }
+    void                AdjustY( long nVertMove ) { nB += nVertMove; }
 
     void                RotateAround( long& rX, long& rY, short nOrientation ) const;
 
@@ -404,10 +404,10 @@ public:
 
     /// Move the top and left edges by a delta, preserving width and height
     inline void         Move( long nHorzMoveDelta, long nVertMoveDelta );
-    void                MoveLeft( long nHorzMoveDelta ) { nLeft += nHorzMoveDelta; }
-    void                MoveRight( long nHorzMoveDelta ) { nRight += nHorzMoveDelta; }
-    void                MoveTop( long nVertMoveDelta ) { nTop += nVertMoveDelta; }
-    void                MoveBottom( long nVertMoveDelta ) { nBottom += nVertMoveDelta; }
+    void                AdjustLeft( long nHorzMoveDelta ) { nLeft += nHorzMoveDelta; }
+    void                AdjustRight( long nHorzMoveDelta ) { nRight += nHorzMoveDelta; }
+    void                AdjustTop( long nVertMoveDelta ) { nTop += nVertMoveDelta; }
+    void                AdjustBottom( long nVertMoveDelta ) { nBottom += nVertMoveDelta; }
     inline void         SetPos( const Point& rPoint );
     void                SetSize( const Size& rSize );
     inline Size         GetSize() const;


More information about the Libreoffice-commits mailing list