[Libreoffice-commits] core.git: sd/source
Sven Lüppken (via logerrit)
logerrit at kemper.freedesktop.org
Mon Nov 2 08:34:50 UTC 2020
sd/source/ui/dlg/BulletAndPositionDlg.cxx | 8 ++++++++
1 file changed, 8 insertions(+)
New commits:
commit d1b6694f843c5bda92e106db6efd36654df9ee9a
Author: Sven Lüppken <sven at slueppken.de>
AuthorDate: Fri Oct 30 08:41:56 2020 +0100
Commit: Heiko Tietze <heiko.tietze at documentfoundation.org>
CommitDate: Mon Nov 2 09:34:11 2020 +0100
tdf#130526 Hide "Apply to Master"-button and rename "Slide" to "Page" in Draw
Both options don't apply in a Draw context and confuse users. This solution was proposed in the bug ticket.
Change-Id: I4f55fd68990e4b7ee3fa6f94bf16a531728ee278
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/105034
Tested-by: Jenkins
Reviewed-by: Heiko Tietze <heiko.tietze at documentfoundation.org>
diff --git a/sd/source/ui/dlg/BulletAndPositionDlg.cxx b/sd/source/ui/dlg/BulletAndPositionDlg.cxx
index b3208cf827f0..bb67585ce8eb 100644
--- a/sd/source/ui/dlg/BulletAndPositionDlg.cxx
+++ b/sd/source/ui/dlg/BulletAndPositionDlg.cxx
@@ -197,6 +197,14 @@ SvxBulletAndPositionDlg::SvxBulletAndPositionDlg(weld::Window* pWindow, const Sf
if (pMetricItem)
SetMetric(static_cast<FieldUnit>(pMetricItem->GetValue()));
+ // tdf#130526: Hide "Apply To Master"-button in Draw and rename "Slide" to "Page"
+ DocumentType aDocumentType = pView->GetDoc().GetDocumentType();
+ if (aDocumentType == DocumentType::Draw)
+ {
+ m_xApplyToMaster->hide();
+ m_xSlideRB->set_label(SdResId(STR_PAGE_NAME));
+ }
+
// End PageCreated
Reset(&rSet);
More information about the Libreoffice-commits
mailing list