[Libreoffice-qa] db test VM

Bernhard M. Wiedemann bernhardout at lsmod.de
Wed Oct 19 07:04:13 PDT 2011

Hash: SHA1

On 10/18/2011 03:21 PM, Petr Mladek wrote:
> Hi,
> first, I am sorry with the late reply. I have attended the LO
> conference last week...
> Bernhard M. Wiedemann píše v St 12. 10. 2011 v 17:57 +0200:
>> -----BEGIN PGP SIGNED MESSAGE----- On 10/10/2011 02:53 PM, Petr
>> Mladek wrote:
>>> We might use Yi Fan's 
>>> http://cgit.freedesktop.org/libreoffice/core/tree/smoketestoo_native/losmoketest.py
I tried to run
>> python losmoketest.py --force --type=daily_master but it kept
>> looping+printing "Checking new build".
>> because this was missing: - --- losmoketest.py.orig 2011-10-12
>> 16:38:10.000000000 +0200 +++ losmoketest.py      2011-10-12
>> 17:31:12.000000000 +0200
> Thanks for the fix. I have pushed it as 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=45afb6635894a812701624ea092a9a812f048671
>> and then "cppunittester" complained about missing
>> libuno_sal.so.3 which can be workarounded with echo
>> /opt/lo-dev/ure/lib > /etc/ld.so.conf.d/lo.conf ; ldconfig
> The script sets LD_LIBRARY_PATH but it used a wrong path. I have
> fixed it.
>> and then an assertion failed in officeconnection.cxx:112... so
>> not really working out-of-the box
> It used a wrong path to services.rdb. I have fixed it as well.
> I did many other changes that might be interesting for you, see 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=c55b2dcceed29c3e9df181b2775099d5b345a4e9
>  So, please, try the last script from 
> http://cgit.freedesktop.org/libreoffice/core/plain/smoketestoo_native/losmoketest.py
>  Feel free to report any problems. Me and Yi Fan will do our best
> to improve it for your needs.
>> and I found that uninstalling the openSUSE libreoffice.rpm
>> complains about missing /usr/sbin/unopkg-sync-bundled
> Just ignore these complains. I need to improve post install script 
> dependencies but it does not break anything.
>> pulling daily builds from OBS could also be an option for us.
> It might take me few days to setup it because I havn't started to
> pack master for openSUSE yet. Anyway, we have wanted the daily repo
> for ages, so I could jump on it if you want. In the meantime, you
> could use packages from the LibreOffice:Unstable repo. It should be
> easy to switch to the new repo if needed.
> I am looking forward to see some testing results.
> Best Regards, Petr


during package install I got
/opt/lo-dev/program/unopkg.bin: error while loading shared libraries:
libpng12.so.0: cannot open shared object file: No such file or directory

which I worked around with a
sudo zypper -n in libpng12-0

This hints toward missing dependencies.

Then some configs or dirs were needed which I got by pulling the
losmoketest-0.2.tar.bz2 that I found by googling.

and then, everything runs.
Though 22 seconds total time for test is surprisingly quick.

if you want to test:

curl http://openqa.opensuse.org/opensuse/qatests/qa_office.sh|sh

Bernhard M.
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Libreoffice-qa mailing list