[Libreoffice] Install problem

sidney sidneym at gmail.com
Fri Oct 1 12:41:23 PDT 2010

Michael Meeks wrote, On 2/10/10 3:46 AM:
> Hi Krishnan,
> On Thu, 2010-09-30 at 19:27 +0530, krishnan parthasarathi wrote:
>> I followed the above test and found that open() calls on pythonloader
>> module were failing with ENOENT. For eg,
> ..
> 	Ok - this is a broken pythonpath issue.
>> From the log file I found that ooinstall is looking for python module
>> in the system directories and not in the python that was built in LO.
> 	Right - so - we added a fix to ooinstall in git master that should make
> this work for you - just update: $ git pull -r # in your top-level
> source directory, and this should be fixed.
> 	Thanks for the report, hope it works for you now,

I don't know whether I built before or after this patch, but someone on IRC
suggested adding the --with-system-python option in the configuration step
which worked for me. Is that a result of this patch or is that option no
longer necessary?

I also found two other tweaks necessary for building on 64-bit Fedora 13. One
was to have --disable-kde. Even though I had first tried installing
kdelib-devel and kde3lib-devel I still got errors that looked like it thought
that some KDE headers were missing. The other was I had to remove the
following four files before running ooinstall or else it complained about the
modules already being installed when it tried to install them a second time

cd build/libreoffice-
rm swext/wiki-publisher.oxt
rm minimizer/presentation-minimizer.oxt
rm pdfimport/pdfimport.oxt
rm presenter/presenter-screen.oxt

Deleting any others of the multiple copies of those four oxt files resulted in
errors, the delete had to be of those four specific ones.

More information about the LibreOffice mailing list