[Libreoffice] the basic macro editor

John Lee Castle jlc at mail2lee.com
Mon Oct 25 06:02:31 PDT 2010

>From: Michael Meeks [michael.meeks at novell.com]
> :-)
> Nasty - some sort of python conflict; 
> Ok - so this should not be a fatal error ...

Tried setting breaks and traces but nothing new .... 

>break _exit
>break exit
> and re-run - and get a trace from the exit call ? :-)

I tried this and was unable to get anymore useful information - likely
because I need to learn gdb better. Did gdb call, setup break points,
run -writer, did Tools->Macro->Run, the result is the same (threads
start then PyUni message and backing out) and gdb doesnt seem to have
any info after the fact.

The lack of info maybe my failure to get it from gdb.
I did try tcatch catch and got an exception right at program startup,
then nothing around crash...

Starting program:
[Thread debugging using libthread_db enabled]
[New Thread 0xb726eb70 (LWP 4876)]
Temporary catchpoint 3 (exception caught), 0x005eb126 in
__cxa_begin_catch ()
(gdb) c

An exception right at the start but again nothing later -- the same
pattern of error statement and exits all the way out. 

> It looks like some conflict between system and internal python - I
>guess you built one, and not the other - perhaps you re-configured
>between the ways, and have stale python libraries in your solver -

I can believe that my system has 'internal conflicts' and more -- even
though this was just after the first successful build on a fresh dev
config I setup over the weekend . I pulled / built several times waiting
for resolution of the URE=%unsubstitutedvariablename that prevented
packaging. A full (new or clean) build takes me 8-12 hours (depending on
other use of computer) - I have done several full builds in last couple
weeks and I am not eager to go there again ... Do you want me to try
rm-f /unxlngi6pro in the solver? And isnt that pretty close to a make
clean on the whole system? 

> I had an easy-hack to hack build.pl to avoid that :-) but ...

Nothing around build/make_install looks like just an 'easy hack' - 
I will do some simple patches first! 

At your service 

<span id=m2wTl><p><font face="Arial, Helvetica, sans-serif" size="2" style="font-size:13.5px">_______________________________________________________________<BR>Get the Free email that has everyone talking at <a href=http://www.mail2world.com target=new>http://www.mail2world.com</a><br>  <font color=#999999>Unlimited Email Storage &#150; POP3 &#150; Calendar &#150; SMS &#150; Translator &#150; Much More!</font></font></span>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20101025/5ea2421f/attachment.htm>

More information about the LibreOffice mailing list