[Libreoffice] Build problem on windows 7

Martin Gallwey martin at gallwey.com
Mon Oct 25 12:00:39 PDT 2010

>> I was going to patch it to do a 'tar --same-owner' instead,
> Hmm, you mean --no-same-owner?

Same thing, no?

> This is mostly a guess, but are you running the build as Administrator 
> (you shouldn't), or does Cygwin for some other reason (broken Cygwin 
> /etc/passwd file?) think you are root (in the Cygwin sense)? Check what 
> the Cygwin "id" command outputs. It should say that you are a "normal" 
> non-root user.

If I run 'rxvt' as 'Administrator' (ie, by right clicking on it and 
clicking the checkbox for 'Run as Administrator'), id shows:

uid=1004(Martin) gid=513(None)

And now the wrinkle. *sometimes* when I run rxvt, I get this:
uid=0(Martin) gid=0(root) groups=0(root),545(Users)

and sometimes I get this:

uid=1004(Martin) gid=513(None) groups=513(None),545(Users)

Okay, it seems that if I have no instances of rxvt running, and start one, 
I get uid 0, and the build fails. If I have one instance of rxvt running 
and start a second, I get uid 1004, and the build succeeds. I have no idea 
why - anyone else encountered this?

Where would be an appropriate place to check the uid and fail with a 
useful hint?

More information about the LibreOffice mailing list