[Libreoffice] Macro Cleanup in UNO
nthiebaud at gmail.com
Sun Oct 31 22:40:24 PDT 2010
On Sun, Oct 31, 2010 at 11:44 PM, Joseph Powers <jpowers27 at cox.net> wrote:
> The defaults for the classes where defined in the header (good); however,
> they used generic names like DEFAULT_VALUE, FREESPACE, … (bad). I went ahead
> and renamed them by prefixing CLASSNAME_ to the start of them. Someone
> already found this issue since I found some #undefs before #defines so the
> values could be changed.
Is there any reason why you didn't apply the same rule for
DEFAULT_BUTTONLABEL (in progessmonitor.hxx) ?
> Joe P.
> PS: I left the CreateFromASCII() work to the other team. I will note that
> anything CreateFromASCII( ALLUPPERCASE ) is a constant and can be optimize
> (check the header file of the same name).
> PS: Patch released under LGPL 3+
> LibreOffice mailing list
> LibreOffice at lists.freedesktop.org
More information about the LibreOffice